Opened 10 years ago

Closed 10 years ago

#11562 closed defect (fixed)

TitlePane: opening an accordion pane causes closed TitlePane's to load href's.

Reported by: neorush Owned by: bill
Priority: high Milestone: 1.6
Component: Dijit Version: 1.5
Keywords: dijit AccordionContainer ContentPane TitlePane Cc:
Blocked By: Blocking:

Description

When there are recursive dijit.TitlePane?'s within a dijit.layout.AccordionContainer? the TitlePane? href always preloads. preload="false" seems to have no effect. With recursive title panes like for categories this is catastrophic as the server requests become exponential the deeper the recursion goes. See attached files for test case.

Attachments (2)

test.html (1.1 KB) - added by neorush 10 years ago.
Test File 1
accordionContent.html (368 bytes) - added by neorush 10 years ago.
Test File 2

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by neorush

Attachment: test.html added

Test File 1

Changed 10 years ago by neorush

Attachment: accordionContent.html added

Test File 2

comment:1 Changed 10 years ago by bill

Component: GeneralDijit
Milestone: tbd1.6
Owner: changed from anonymous to bill
Status: newassigned
Summary: dijit.TitlePane href Always PreloadsTitlePane: href Always Preloads

I'll fix. It's when a ContentPane inside an AccordionContainer (or a TabContainer) is first shown, and calls resize() on it's children, in case they need to layout themselves. For complicated reasons, resize() on a TitlePane (or any descendant of ContentPane) causes the href to load... The problem is that resize() on a closed TitlePane shouldn't do that.

comment:2 Changed 10 years ago by bill

Summary: TitlePane: href Always PreloadsTitlePane: opening an accordion pane causes closed TitlePane's to load href's.

comment:3 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [22727]) Fix so closed TitlePane's inside of AccordionContainer's don't load their href too soon, fixes #11562 !strict.

Note: See TracTickets for help on using tickets.