Opened 9 years ago

Closed 7 years ago

#11552 closed defect (duplicate)

IE8 calling setShape on dojox.gfx.Rect erases all registered events

Reported by: elbeau Owned by: Eugene Lazutkin
Priority: high Milestone: future
Component: DojoX GFX Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Eugene Lazutkin)

in dojox/gfx/vml.js on lines 342 to 347 the code replaces this.rawNode for the Rect shape as follows:

if(d.isIE > 7){
    var node = this.rawNode.ownerDocument.createElement("v:roundrect");
    node.arcsize = r;
    node.style.display = "inline-block";
    this.rawNode = node;
}

By replacing this node, any registered node events (ie: onmousedown for me) disappear because they are not copied to the new node.

This is easily replicated by creating a dojox.gfx.Rect then registering an event (I add a mover) then calling setShape.

This ONLY affects IE 8

Change History (2)

comment:1 Changed 9 years ago by Eugene Lazutkin

Description: modified (diff)
Milestone: tbdfuture
Priority: highnormal
severity: majornormal
Status: newassigned

comment:2 Changed 7 years ago by Patrick Ruzand

Resolution: duplicate
Status: assignedclosed

Duplicate of #15638.

Note: See TracTickets for help on using tickets.