Opened 9 years ago

Closed 9 years ago

#11496 closed defect (worksforme)

ProgressBar: changing from indeterminate w/label to determinate leaves previous label visible

Reported by: Becky Gibson Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.5
Keywords: Cc: dante
Blocked By: Blocking:

Description

If you have an indeterminate progress bar with a label and then change it to a determinate progress bar, the indeterminate label remains rather than the new percent label.

1) Load test_ProgressBar.html

2) Click the Make Indeterminate button at the bottom of the page - the bottom bar has the indeterminate image visible.

3) Click the Make Determinate button at the bottom of the page - the bar shows 50%

4) Click the Make Indeterminate with Label button - the bar shows the indeterminate image with the label "loading..."

5) Click the Make Determinate button at the bottom of the page - the bar still shows "Loading ..." rather than 50% as it should.

Change History (3)

comment:1 Changed 9 years ago by bill

That's the intended behavior, although admittedly the test file is confusing. I wrote this in the API spec:

// label: String?
//		Label on progress bar.   Defaults to percentage for determinate progress bar and
//		blank for indeterminate progress bar.
label:"",

I meant that the user can set an explicit label for either determinate or indeterminate mode. Perhaps that wasn't clear?

Often determinate progress bars have text labels. Actually our test file has an example of that. Here's another one, see the purple progress bar at the bottom.

Is there a problem?

comment:2 Changed 9 years ago by bill

(In [22614]) make tests about custom label (for both determinate and indeterminate progress bar) clearer, refs #4322, #11496.

comment:3 Changed 9 years ago by bill

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.