Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#11440 closed enhancement (fixed)

[patch][cla] dojox.dtl._DomTemplated - have buildRendering create a div if there is no srcNodeRef

Reported by: ben hockey Owned by: Neil Roberts
Priority: high Milestone: 1.8
Component: DojoX DTL Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description

change dojox.dtl._DomTemplated to have buildRendering create a div if the is no srcNodeRef provided. this is how dijit._Widget works.

Attachments (2)

11440.diff (870 bytes) - added by ben hockey 9 years ago.
11440.html (1.9 KB) - added by ben hockey 9 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by ben hockey

aargh... i forgot that this would need a change to dojox.dtl.render.dom.Render as well so that it could render without a parent node. not sure if you would want to make that change as well but i'll update the patch to include it and i'll also attach a test case.

Changed 9 years ago by ben hockey

Attachment: 11440.diff added

Changed 9 years ago by ben hockey

Attachment: 11440.html added

comment:2 Changed 8 years ago by Remoun Metyas

This issue feels unloved.

But really, why hasn't this patch been accepted into trunk yet?

comment:3 Changed 7 years ago by ben hockey

#14841 is a duplicate of this ticket.

comment:4 Changed 7 years ago by Michael Wu

Hi, I have verified that this patch works for the issue reported in #14841. I patched against 1.7.2. Hope this can get merged back to trunk. Thanks.

comment:5 Changed 7 years ago by ben hockey

Resolution: fixed
Status: newclosed

In [27957]:

fixes #11440

comment:6 Changed 7 years ago by bill

Milestone: tbd1.8
Note: See TracTickets for help on using tickets.