Opened 13 years ago

Closed 7 years ago

#1144 closed defect (wontfix)

Dojo leaks in frames in IE

Reported by: sol@… Owned by: dylan
Priority: low Milestone: future
Component: Core Version: 0.3
Keywords: IE frame memory+leak needsreview Cc: sol@…
Blocked By: Blocking:

Description (last modified by bill)

Hey. It seem Dojo leaks in frames. When a page with Dojo is shown in a frame it seems dojo doesn't unload at all(?) or leaks for whatever other reason.

Simple case of just loading dojo.js with an empty page (with no other script) in a frame shows the memory leak. The leak is small (but still present) for referencing dojo in repository (not baked, when dojo.js is small), but is really a problem for built dojo (baked, dojo.js.uncompressed.js).

For release I get about 0.8MB leak for each frame on refresh. I suspect any widgets present on the page add to the leak. Perhaps unload procedure isn't run properly in the frame?

To reproduce - unpack attachment to the root of the dojo source repository (together with dojo.js file). Load test_frames.html. The problem isn't as noticeable with fresh (not built dojo) as it is with baked dojo.

I used Drip (http://outofhanwell.com/ieleak/index.php?title=Main_Page) to monitor memory usage.

Attachments (2)

test-frames.zip (568 bytes) - added by sol@… 13 years ago.
Test file to reproduce the problem.
test2-frames.rar (511 bytes) - added by ornus 13 years ago.
Test file that uses baked dojo.

Download all attachments as: .zip

Change History (22)

Changed 13 years ago by sol@…

Attachment: test-frames.zip added

Test file to reproduce the problem.

comment:1 Changed 13 years ago by mwubben@…

comment:2 Changed 13 years ago by ornus

Actually, I think it could. Thanks. The test case I provided forces IE to jump in memory consumption, but it seems to stabilize after a while. I guess the problem got fixed.

Changed 13 years ago by ornus

Attachment: test2-frames.rar added

Test file that uses baked dojo.

comment:3 Changed 13 years ago by ornus

The problem is still there, especially with baked dojo (which most of the people will use). Download and unpack test2-frames to the trunk check-out folder. It assumes that built dojo is in release/dojo.

comment:4 Changed 13 years ago by liucougar

Cc: sol@… added

could you confirm whether this issue is still the case with trunk?

comment:5 Changed 13 years ago by ornus

Yep. It's still an issue. Baked dojo leaks much more than non-baked, but the leak is still there.

comment:6 Changed 13 years ago by dylan

Milestone: 0.40.4.1

comment:7 Changed 13 years ago by bill

Milestone: 0.4.10.5

comment:8 Changed 13 years ago by alex

Milestone: 0.50.4.1

why was this moved?

comment:9 Changed 13 years ago by ornus

just to let you know this is still an issue.

comment:10 Changed 13 years ago by bill

Milestone: 0.4.10.5

Pushing to 0.5 since we ran out of time on 0.4.1.

comment:11 Changed 12 years ago by guest

Is it related to ticket #3242?

Konstantin Kolinko

comment:12 Changed 12 years ago by guest

not a clue, maybe

comment:13 Changed 12 years ago by alex

Milestone: 0.91.0

comment:14 Changed 12 years ago by bill

Milestone: 1.11.2

comment:15 Changed 11 years ago by bill

Description: modified (diff)
Milestone: 1.2future

comment:16 Changed 9 years ago by Chris Mitchell

Owner: changed from alex to dylan

please review/triage

comment:17 Changed 9 years ago by dylan

Priority: highestnormal

I don't believe this has been an issue for years, but I suggest we test it for 1.8 and close it out for good if not an issue.

comment:18 Changed 8 years ago by ben hockey

Keywords: needsreview added
Priority: highlow

comment:19 Changed 8 years ago by bill

There's still a memory increase as can be seen from the attached testcase on IE6. I ran:

./build.sh profile=standard releaseDir=../../release action=release

And then loaded test2_frames.html repeatedly on IE6:

page loadsmemory usage
1st15.8M
10th18.1M
20th18.5M
30th19M

It's pretty small though. Probably you should close this ticket as wontfix, because probably we won't fix it.

comment:20 Changed 7 years ago by dylan

Resolution: wontfix
Status: newclosed

Very small leaks remain. This won't be an issue with 2.x, so closing this out.

Note: See TracTickets for help on using tickets.