Opened 9 years ago

Closed 9 years ago

#11422 closed defect (invalid)

[regression] dojox mobile styles do not render in 1.5.0rc2; worked fine in 1.5.0b3

Reported by: scheid Owned by: Shane O'Sullivan
Priority: high Milestone: 1.6
Component: DojoX Mobile Version: 1.5.0rc1
Keywords: mobile Cc:
Blocked By: Blocking:

Description

Hi,

I just moved from 1.5.0b3 to 1.5.0rc2 and the mobile styles do not seem to render correctly for dojox.mobile.EdgeToEdgeCategory?, dojox.mobile.EdgeToEdgeList?, dojox.mobile.Heading, dojox.mobile.ListItem?, etc.

I tested in both Firefox 3.6 and Chrome 5.0 on my laptop machine (Win XP) and also in Safari on iPhone OS 3.1.3

In 1.5.0b3, the mobile styles rendered great, but the same pages appear as unstyled elements when moving to 1.5.0rc2. When I moved back down to 1.5.0b3 without changing any other code, the mobile styles rendered correctly. So, seems to be specific to rc2. I based my code on http://docs.dojocampus.org/dojox/mobile .

Unsure how to troubleshoot as Firebug doesn't show any errors either in Firefox or Chrome. My hunch is that it's a css issue, and not a js, etc. error. I have a site up and running with this code, but it is an internal IBM site; let me know if you would be able to access that address.

BTW, I'm really excited about these mobile pages; they will greatly facilitate a project I'm working on. Great job on them so far!!

Attachments (1)

dojox-mobile-test-1.htm (1.1 KB) - added by scheid 9 years ago.
test file for ticket 11422

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by bill

Component: GeneralDojoX Mobile
Milestone: tbd1.5
Owner: changed from anonymous to Shane O'Sullivan
Summary: dojox mobile styles do not render in 1.5.0rc2; worked fine in 1.5.0b3[regression] dojox mobile styles do not render in 1.5.0rc2; worked fine in 1.5.0b3

comment:2 Changed 9 years ago by Shane O'Sullivan

I cannot reproduce this issue. I have tested on Firefox and Safari and iPhone Simulator on Mac and all of the elements you mention work perfectly well.

Can you try again, clearing cache?

comment:3 Changed 9 years ago by scheid

OK, will do. I'll clear everything out and try it again.

comment:4 Changed 9 years ago by scheid

OK, I cleared the caches for Firefox and Chrome, and I also even did an install of Safari 5.0 on my laptop machine, and still all showed the same result: plain, unstyled elements. In looking at the rendered HTML in Firebug, appears like the raw HTML is not even being parsed by the dojo parser. This must be some quirk in how I coded up my page, as you cannot reproduce it.

I will post a sample file demonstrating this behavior. . .

comment:5 Changed 9 years ago by Adam Peller

Milestone: 1.51.6

Changed 9 years ago by scheid

Attachment: dojox-mobile-test-1.htm added

test file for ticket 11422

comment:6 Changed 9 years ago by scheid

OK, I have done some more testing with this. I've used the just released dojo 1.5 version, and still I see the same results: unstyled incorrectly rendered mobile pages. When I switch back to beta version 1.5b3, the page renders correctly. The attached test file (see dojox-mobile-test-1.htm) is a simple test page I have been using.

comment:7 Changed 9 years ago by scheid

OK, I'm kicking myself. When I add djConfig="parseOnLoad: true" to the dojo.js script tag everything works fine. I should have noticed that before. So, I think this ticket can be closed.

comment:8 Changed 9 years ago by Shane O'Sullivan

Resolution: invalid
Status: newclosed

Good to hear, closing.

Note: See TracTickets for help on using tickets.