Opened 9 years ago

Closed 9 years ago

#11414 closed defect (wontfix)

weird apperance when create tabContainer inside TitlePane programmatically .CCLA.

Reported by: JayZ(zhouxiang) Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.5.0b2
Keywords: Cc: xiangxz@…, wjiaye@…
Blocked By: Blocking:

Description

when create tabContainer inside titlePane, the tabcontainer looks weird, please refer to the attached test case (test_TitlePane_with_TabContainer.html)

Attachments (1)

test_TitlePane_with_TabContainer.html (2.0 KB) - added by JayZ(zhouxiang) 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by JayZ(zhouxiang)

comment:1 Changed 9 years ago by bill

Resolution: wontfix
Status: newclosed

I see this bug report every few months. The problem is that TabContainer is waiting for TitlePane to call resize() on it, but TitlePane doesn't even know that the TabContainer exists.

The only supported way to add content to the TitlePane (or any ContentPane based widget) is to call set("content", ...) or set("href", ...). You should do it that way, or if you need to muck with the TitlePane contents manually, then call TabContainer.resize() after TabContainer.startup().

Note: See TracTickets for help on using tickets.