Opened 9 years ago

Closed 9 years ago

#11401 closed defect (worksforme)

Safari5: diji.tests.robot.ContentPaneLayout test failures

Reported by: Chris Mitchell Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

GROUP "dijit.tests.layout.ContentPaneLayout" has 1 test to run
 21 tests to run in 6 groups
 ------------------------------------------------------------
 GROUP "startup events" has 1 test to run
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::startup events::startup on href pane's children 4001 ms
 ------------------------------------------------------------
 GROUP "load events" has 7 tests to run
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::load events::initial conditions 4000 ms
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::load events::reset href in hidden pane, pane2 750 ms
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::load events::reset href in hidden pane, innerPane1 751 ms
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::load events::reset href in hidden pane, bcPane2 751 ms
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::load events::selecting ContentPane causes it to load 4025 ms
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::load events::selecting a TabContainer causes it's selected child to load 4023 ms
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::load events::selecting a BorderContainer causes it's children to load 4019 ms
 ------------------------------------------------------------
 GROUP "resize events" has 4 tests to run
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::resize events::single child 15 ms
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::resize events::multiple children 10 ms
     _AssertFailure: doh._AssertFailure: assertTrue('undefined') failed with hint: 
 		href was loaded and top level BorderContainer was created
: assertTrue('undefined') failed with hint: 
		href was loaded and top level BorderContainer was created
     ERROR IN:
 		 function (t) {
							var d = new doh.Deferred();

							dijit.byId("resizeTC").selectChild(dijit.byId("singleChildHref"))

							// Wait for load events to occur (after fetching URL's)
							setTimeout(d.getTestCallback(function(){
								// Check top level border container got sized to fit ContentPane
								var child = dijit.byId("singleChildHrefBorderContainer");
								doh.t(child, "href was loaded and top level BorderContainer was created")
								doh.t(layoutResizes["singleChildHrefBorderContainer"], "got resize event");
								doh.t(layoutResizes["singleChildHrefBorderContainer"][0].length, "got size specified")

								var size = layoutResizes["singleChildHrefBorderContainer"][0][0];
								doh.t(size && size.h, "non-0 height specified");
								doh.t(size && size.w, "non-0 width specified");

								// Check that resize() events also trickled down to inner TabContainer
								var child2 = dijit.byId("singleChildHrefInnerTabContainer");
								doh.t(child2, "inner TabContainer was created")
								doh.t(layoutResizes["singleChildHrefInnerTabContainer"], "got resize event");
								doh.is(0, layoutResizes["singleChildHrefInnerTabContainer"][0].length, "no size specified")
							}), 4000);
							return d;
						}
 FAILED test: ../../dijit/tests/layout/ContentPaneLayout.html::resize events::single resizable href 4013 ms
     _AssertFailure: doh._AssertFailure: assertTrue('undefined') failed with hint: 
 		TabContainer was created
: assertTrue('undefined') failed with hint: 
		TabContainer was created
     ERROR IN:
 		 function (t) {
							var d = new doh.Deferred();

							dijit.byId("resizeTC").selectChild(dijit.byId("multipleChildHref"))

							// Wait for load events to occur (after fetching URL's)
							setTimeout(d.getTestCallback(function(){
								// Check that resize() done on TabContainer
								var child = dijit.byId("multipleChildHrefTabContainer");
								doh.t(child, "TabContainer was created")
								doh.t(layoutResizes["multipleChildHrefTabContainer"], "got resize event");
								doh.is(0, layoutResizes["multipleChildHrefTabContainer"][0].length, "no size specified")
							}), 4000);
							return d;
						}
 FAILED test: ../../dijit/tests/layout/ContentPaneLayout.html::resize events::multiple resizable href 4015 ms
 ------------------------------------------------------------
 GROUP "TitlePane" has 4 tests to run
     _AssertFailure: doh._AssertFailure: assertEqual() failed:
 	expected
		1
	but got
		undefined

 with hint: 
		otpHmc loaded on page load
: assertEqual() failed:
	expected
		1
	but got
		undefined

 with hint: 
		otpHmc loaded on page load
     ERROR IN:
 		 function (t) {
							var d = new doh.Deferred();

							var tp = dijit.byId("otpHmc");

							// Allow time for href to load
							setTimeout(d.getTestCallback(function(){
								// Check that href loaded
								doh.is(1, loadEvents["otpHmc"], "otpHmc loaded on page load");

								// Check that resize() done on children
								doh.t(layoutResizes["otpHmcBorderContainer"], "got resize event for BC");
								doh.t(layoutResizes["otpHmcTabContainer"], "got resize event for TC");
								doh.is(0, layoutResizes["otpHmcBorderContainer"][0].length, "no size specified for BC")
							}), 4000);

							return d;
						}
 FAILED test: ../../dijit/tests/layout/ContentPaneLayout.html::TitlePane::initially open, href multiple children 4002 ms
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::TitlePane::initially open, multiple children 0 ms
     _AssertFailure: doh._AssertFailure: assertEqual() failed:
 	expected
		1
	but got
		undefined

 with hint: 
		ctpHmc loaded when expanded
: assertEqual() failed:
	expected
		1
	but got
		undefined

 with hint: 
		ctpHmc loaded when expanded
     ERROR IN:
 		 function (t) {
							var d = new doh.Deferred();

							doh.f(loadEvents["ctpHmc"], "ctpHmc load deferred until open");

							var tp = dijit.byId("ctpHmc");
							tp.set("open", true);

							// Allow time for href to load, pane to expand, and resize to be called on children
							setTimeout(d.getTestCallback(function(){
								// Check that href loaded
								doh.is(1, loadEvents["ctpHmc"], "ctpHmc loaded when expanded");

								// Check that resize() done on children
								doh.t(layoutResizes["ctpHmcBorderContainer"], "got resize event for BC");
								doh.t(layoutResizes["ctpHmcTabContainer"], "got resize event for TC");
								doh.is(0, layoutResizes["ctpHmcBorderContainer"][0].length, "no size specified for BC")
							}), 4000);

							return d;
						}
 FAILED test: ../../dijit/tests/layout/ContentPaneLayout.html::TitlePane::initially closed, href multiple children 4022 ms
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::TitlePane::initially closed, multiple children 769 ms
 ------------------------------------------------------------
 GROUP "Dialog" has 2 tests to run
     _AssertFailure: doh._AssertFailure: assertEqual() failed:
 	expected
		1
	but got
		undefined

 with hint: 
		dlgHmc loaded when expanded
: assertEqual() failed:
	expected
		1
	but got
		undefined

 with hint: 
		dlgHmc loaded when expanded
     ERROR IN:
 		 function (t) {
							var d = new doh.Deferred();

							doh.f(loadEvents["dlgHmc"], "dlgHmc load deferred until open");

							var dlg = dijit.byId("dlgHmc");
							dlg.show();

							// Allow time for href to load, pane to expand, and resize to be called on children
							setTimeout(d.getTestCallback(function(){
								// Check that href loaded
								doh.is(1, loadEvents["dlgHmc"], "dlgHmc loaded when expanded");

								// Check that resize() done on children
								doh.t(layoutResizes["dlgHmcBorderContainer"], "got resize event for BC");
								doh.t(layoutResizes["dlgHmcTabContainer"], "got resize event for TC");
								doh.is(0, layoutResizes["dlgHmcBorderContainer"][0].length, "no size specified for BC")
							}), 4000);

							return d;
						}
 FAILED test: ../../dijit/tests/layout/ContentPaneLayout.html::Dialog::href multiple children 4017 ms
 PASSED test: ../../dijit/tests/layout/ContentPaneLayout.html::Dialog::multiple inlined children 766 ms

Change History (5)

comment:1 Changed 9 years ago by bill

Description: modified (diff)

!dijit/tests/layout/ContentPaneLayout.html is running fine for me on mac (on safari5). Even util/doh/runner.html?testModule=dijit.tests.layout.module works for me. Might be a timing problem but I can't debug it since it doesn't reproduce for me. Anything you could add to help debug it? Does the standalone testcase fail for you?

comment:2 Changed 9 years ago by Chris Mitchell

Able to reproduce on separate run. Safari Version 5.0 (6533.16), Mac OSX SnowLeopard? x64

comment:3 Changed 9 years ago by Chris Mitchell

Also able to reproduce on separate OS Safari Version 5.0 (7533.16), Windows7 x64

comment:4 Changed 9 years ago by bill

Maybe you just don't have PHP enabled. Does dijit/tests/layout/multipleLayoutWidgets.php?id=otpHmc return plain HTML or PHP for you?

comment:5 Changed 9 years ago by bill

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.