Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#114 closed defect (fixed)

wipeIn/Out remebers new size if triggered during a wipe effect

Reported by: ktiedt@… Owned by: Bryan Forbes
Priority: high Milestone:
Component: General Version: 0.1
Keywords: wipeOut wipeIn effects Cc: alex@…
Blocked By: Blocking:

Description

if you have a wipeOut/In effect and during the wipe you retrigger the effect, it will start over remembering the current size of the wipeOut area and never restore the item to its original size during that instance of the page.

example can be seen at http://dev.xnet.org/ajax/ (users list is the longest one and eastiest to trip this bug on)

-Karl

Change History (10)

comment:1 Changed 14 years ago by david

Owner: changed from anonymous to david
Status: newassigned

The problem is that "playing nicely" isn't always so easy. So, for example, if you hardcoded the height of an element, then you wouldn't want wipeIn/Out to set the height to auto when it is done. On the other hand, if you haven't set an explicit height, you'd want the wipeIn/Out to leave the height at auto when it is done. At the moment, I don't know how to get around this shortcoming, but you can use a callback to get the desired effect:

dojo.fx.wipeIn(node, 100, function(e) {
 e.style.height = 'auto';
}

comment:2 Changed 14 years ago by alex

Cc: alex@… added
Milestone: 0.3release

comment:3 Changed 14 years ago by ktiedt@…

Cc: alex@… removed
Milestone: 0.3release

Not sure if this is possible inside the effects code... but this is how I circumvented the problem

I set a global variable "isWiping" and my calls ot wipeXXX would set it to true, and the onClick event would halt if isWiping == true... and on the callback, reset isWiping to false.

It would make sense I would think to add a generic "state" checking process to all the effects... it would certainly allow for preventing problems such as this.

comment:4 Changed 14 years ago by alex

Cc: alex@… added
Milestone: 0.3release

comment:5 Changed 13 years ago by sjmiles

Milestone: 0.3release0.3.1

comment:6 Changed 13 years ago by alex

Owner: changed from david to Bryan Forbes
Status: assignednew

Bryan: are should we close or punt this based on the dojo.lfx work? does lfx have the same problem?

comment:7 Changed 13 years ago by Bryan Forbes

Resolution: wontfix
Status: newclosed

Invalid because of how lfx works. If you want it to remember the old size, you need to use a propertyAnimation with specific values.

comment:8 Changed 13 years ago by anonymous

Resolution: wontfix
Status: closedreopened

I've been told that this is fixed in lfx, so I'm reopening and properly closing this bug.

comment:9 Changed 13 years ago by anonymous

Resolution: fixed
Status: reopenedclosed

comment:10 Changed 12 years ago by (none)

Milestone: 0.3.1

Milestone 0.3.1 deleted

Note: See TracTickets for help on using tickets.