Opened 9 years ago

Closed 9 years ago

#11398 closed defect (worksforme)

Safari5: diji.tests.robot.TitlePane test failures

Reported by: Chris Mitchell Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description

GROUP "dijit.tests.robot.TitlePane?" has 1 test to run

10 tests to run in 4 groups ------------------------------------------------------------ GROUP "api" has 3 tests to run PASSED test: ../../dijit/tests/robot/TitlePane.html::api::setup 0 ms PASSED test: ../../dijit/tests/robot/TitlePane.html::api::title 0 ms PASSED test: ../../dijit/tests/robot/TitlePane.html::api::open 507 ms ------------------------------------------------------------ GROUP "keyboard" has 3 tests to run

_AssertFailure: doh._AssertFailure: assertEqual() failed:

expected

[object HTMLButtonElement]

but got

[object HTMLDivElement]

with hint:

focused on title button after pane

: assertEqual() failed:

expected

[object HTMLButtonElement]

but got

[object HTMLDivElement]

with hint:

focused on title button after pane

ERROR IN:

function () {

var d = new doh.Deferred();

dijit.focus(dojo.byId("input"));

should go to title bar doh.robot.keyPress(dojo.keys.TAB, 500, {});

doh.robot.sequence(d.getTestErrback(function(){

doh.is(pane1.focusNode, dojo.global.dijit._curFocus,"focused on pane1 title")

}), 500);

should skip hidden content and go to button doh.robot.keyPress(dojo.keys.TAB, 500, {});

doh.robot.sequence(d.getTestErrback(function(){

doh.is(dojo.byId("titleButton"), dojo.global.dijit._curFocus,"focused on title button after pane")

}), 500);

go back to title bar doh.robot.keyPress(dojo.keys.TAB, 500, {shift: true});

doh.robot.sequence(d.getTestCallback(function(){

doh.is(pane1.focusNode, dojo.global.dijit._curFocus,"focused on pane1 title")

}), 500);

return d;

}

FAILED test: ../../dijit/tests/robot/TitlePane.html::keyboard::tabbing 2012 ms

Change History (4)

comment:1 Changed 9 years ago by bill

util/doh/runner.html?testModule=dijit.tests.general-module works for m on mace. Might be a timing problem but I can't debug it since it doesn't reproduce for me. Anything you could add to help debug it? Does the standalone testcase fail for you?

comment:2 Changed 9 years ago by Chris Mitchell

Able to reproduce on separate run. Safari Version 5.0 (6533.16), Mac OSX SnowLeopard? x64

comment:3 Changed 9 years ago by Chris Mitchell

Not able to reproduce on Safari Version 5.0 (7533.16), Windows7 x64

comment:4 Changed 9 years ago by bill

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.