Opened 9 years ago

Closed 9 years ago

#11397 closed defect (worksforme)

Safari5: dijit.tests.robot.Tooltip_a11y failures

Reported by: Chris Mitchell Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description

GROUP "dijit.Tooltip keyboard tests" has 3 tests to run

PASSED test: ../../dijit/tests/robot/Tooltip_a11y.html::dijit.Tooltip keyboard tests::show on focus 2504 ms

_AssertFailure: doh._AssertFailure: assertTrue('false') failed with hint:

tooltip hidden

: assertTrue('false') failed with hint:

tooltip hidden

ERROR IN:

function () {

var d = new doh.Deferred();

Tab off of the "button w/tooltip" to the "remove button", which doesn't have a tooltip doh.robot.keyPress(dojo.keys.TAB, 500, {});

doh.robot.sequence(d.getTestCallback(function(){

doh.t(masterTT && isHidden(masterTT.domNode), "tooltip hidden");

}), 2000);

return d;

}

FAILED test: ../../dijit/tests/robot/Tooltip_a11y.html::dijit.Tooltip keyboard tests::hide on blur 2504 ms

_AssertFailure: doh._AssertFailure: assertEqual() failed:

expected

tooltip on a select

but got

tooltip for #1

lon

with hint:

tooltip text

: assertEqual() failed:

expected

tooltip on a select

but got

tooltip for #1

lon

with hint:

tooltip text

ERROR IN:

function () {

var d = new doh.Deferred(),

around = dojo.byId("seven");

Tab off of the "remove button" to the <select> doh.robot.keyPress(dojo.keys.TAB, 500, {});

doh.robot.sequence(d.getTestCallback(function(){

doh.t(masterTT && isVisible(masterTT.domNode), "tooltip shown");

make sure tooltip is on the screen (in LTR mode it needs to go to the left of the <select>, not to the right like it usually does) var viewportCoords = dojo.window.getBox(),

tooltipCoords = dojo.position(masterTT.domNode);

console.log("viewport coords: ", viewportCoords, "tooltip coords: ", tooltipCoords); doh.t(tooltipCoords.x > 0, "x > 0"); doh.t(tooltipCoords.x + tooltipCoords.w <= viewportCoords.w, "t.x + t.w"); doh.t(tooltipCoords.y > 0, "y > 0"); doh.t(tooltipCoords.y + tooltipCoords.h <= viewportCoords.h, "t.y + t.h");

Make sure it has the new content. There's a newline in this tooltip text, so to make comparison easier do substr() doh.is("tooltip on a select", dojo.trim(innerText(masterTT.domNode)).substr(0, 19), "tooltip text");

}), 2000);

return d;

}

FAILED test: ../../dijit/tests/robot/Tooltip_a11y.html::dijit.Tooltip keyboard tests::show another tooltip 2503 ms

Change History (3)

comment:1 Changed 9 years ago by bill

!Tooltip_a11y.html is running fine for me on both windows and mac (on safari5). Even util/doh/runner.html?testModule=dijit.tests.general-module works for me. Might be a timing problem but I can't debug it since it doesn't reproduce for me. Anything you could add to help debug it? Does the standalone testcase fail for you?

comment:2 Changed 9 years ago by Chris Mitchell

Able to reproduce on separate run. Safari Version 5.0 (6533.16), Mac OSX SnowLeopard? x64

comment:3 Changed 9 years ago by bill

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.