Opened 9 years ago

Closed 3 years ago

#11391 closed defect (invalid)

FileInputAuto hangs on Safari 5

Reported by: wangxxi Owned by: wangxxi
Priority: high Milestone: 1.13
Component: DojoX Form Version: 1.5.0b2
Keywords: Cc: liucougar
Blocked By: Blocking:

Description

We checked it's code and notice the its key implementation is

dojo.io.iframe.send({

url: this.url, form: _newForm, handleAs: "json", handle: dojo.hitch(this,"_handleSend")

});

seems dojo.io.iframe is not stable as it sometimes will lose the connection to the target server.

Any idea what is the cause ? or can you suggest a file upload widget we can use which may not use iframe to send the file.

Change History (9)

comment:1 Changed 9 years ago by Adam Peller

Cc: liucougar added
Owner: changed from anonymous to dante

comment:2 Changed 9 years ago by Adam Peller

Do you have a test to reproduce this?

comment:3 Changed 9 years ago by wangxxi

some weird finding is

in case we stop the execution of _fireNextRequest in dojo.io.iframe (after the fn.submit() call, we added some error deliberately ) , seems the upload can go on ( we did tests on 2 machines, it did uploaded the file) , but it would break the other part ( like other callbacks). It is really weird

fn.submit();

add this error code to break the execution

dojo.console.log(fn);

comment:4 Changed 9 years ago by JayZ(zhouxiang)

actually I've checked the test case in dojox/form/tests/test_FileInput.html on safari, it works fine. could you share us a runnable test case?

comment:5 Changed 9 years ago by JayZ(zhouxiang)

As we tested FileInputAuto? widget, this issue(file upload does not work) mostly happens in following situation: 1> Safari5 2> "https" 3> these three things: "browser", "https server" and the "url parameter of FileInputAuto? Widget" are all in three different machine

comment:6 Changed 9 years ago by JayZ(zhouxiang)

The "url parameter of FileInputAuto?? Widget" is customized in dojox/form/tests/test_FileInput.html

<p class="tundra">

<input dojoType="dojox.form.FileInputAuto?" id="defaultAuto2onchange" blurDelay="10" name="inputFileAuto2" triggerEvent="onchange" url="../resources/RecieveFile.php" onComplete="sampleCallback"/> </p>

Some guy says to solve this problem, we can change the http header, set "connection" to "close" instead of "keep-alive". I don't know if anyone have already met such issue, how to set http header in form and is it really work?

comment:7 Changed 9 years ago by wangxxi

any one has any progress on this issue ? this issue is kind of blocking issue. Thanks.

comment:8 Changed 3 years ago by dylan

Component: GeneralDojoX Form
Milestone: tbd1.12
Owner: changed from dante to wangxxi
Status: newpending

Given that this unfortunately hasn't been touched in five years and Safari 5 isn't used much at all, we would need to know if this is still an issue and if someone wants to fix it.

comment:9 Changed 3 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.