Opened 13 years ago

Closed 12 years ago

#1139 closed enhancement (worksforme)

[patch][cla] Get Editor2 Widget to work better with Safari

Reported by: guest Owned by: liucougar
Priority: high Milestone: 0.9
Component: Editor Version: 0.3
Keywords: Cc: hannes.wyss@…
Blocked By: Blocking:

Description

Subject says it all. See also the comments in the code.

The formatblock implementation breaks undo, unfortunately.

See attached Patch against 0.3.1

Cheers Hannes

Attachments (2)

dojo.editor.diff (11.9 KB) - added by hannes.wyss@… 13 years ago.
Patch against 0.3.1
dojo.editor.2.diff (12.1 KB) - added by hannes.wyss@… 13 years ago.
corrected patch against 0.3.1

Download all attachments as: .zip

Change History (15)

Changed 13 years ago by hannes.wyss@…

Attachment: dojo.editor.diff added

Patch against 0.3.1

Changed 13 years ago by hannes.wyss@…

Attachment: dojo.editor.2.diff added

corrected patch against 0.3.1

comment:1 Changed 13 years ago by bill

Component: GeneralWidgets
Owner: changed from anonymous to liucougar
Summary: Get Editor2 Widget to work better with Safari[patch] Get Editor2 Widget to work better with Safari

Hannes - thanks for the patch but we need you to sign the cla (http://dojotoolkit.org/icla.txt) before we can look at it.

comment:2 Changed 13 years ago by guest

My signed ICLA should be in your Fax-Intray (sent to +1 650 618 2011, no errors on my side) since the beginning of this week - would you mind doublechecking?

Hannes

comment:3 Changed 13 years ago by dylan

Milestone: 0.4

confirmed, cla on file

comment:4 Changed 13 years ago by liucougar

could you please update the patch against latest svn?

thanks

comment:5 Changed 13 years ago by liucougar

Owner: changed from liucougar to alex

comment:6 Changed 13 years ago by dylan

Summary: [patch] Get Editor2 Widget to work better with Safari[patch][cla] Get Editor2 Widget to work better with Safari

comment:7 Changed 13 years ago by dylan

Contacted Hannes to see if we can get a patch in time for 0.4

comment:8 Changed 13 years ago by dylan

Owner: changed from alex to dylan

comment:9 Changed 13 years ago by dylan

Milestone: 0.40.5

We're going to need to push this back a bit unfortunately. given that Hannes is busy and I don't want to break the Editor2 widget.

comment:10 Changed 13 years ago by bill

Milestone: 0.91.0
Owner: changed from dylan to liucougar

We aren't supporting Safari 2.0.4; is this a problem in latest webkit?

comment:11 Changed 13 years ago by Adam Peller

Component: WidgetsDijit

comment:12 Changed 12 years ago by bill

Component: DijitEditor

comment:13 Changed 12 years ago by liucougar

Milestone: 1.00.9
Resolution: worksforme
Status: newclosed

no further info, closing

Note: See TracTickets for help on using tickets.