Opened 9 years ago

Closed 9 years ago

#11385 closed defect (fixed)

[regression] dojox grid classes: get method collisions in 1.5?

Reported by: Kenneth G. Franqueiro Owned by: Kris Zyp
Priority: high Milestone: 1.5
Component: DojoX Grid Version: 1.5.0rc1
Keywords: dojox, grid Cc:
Blocked By: Blocking:

Description

I probably don't know the full story here, but I'm seeing what look like regressions lurking around the dojox grid classes in 1.5.

Firstly, dojox/grid/tests/test_change_structure.html fails, with the error "this.get is not a function". Indeed, upon inspection, the grid's get property is null, seemingly brought upon by code in _Grid's buildRendering function.

The thing is, it would appear that dojox.grid._Grid (and DataGrid) actually have their own get methods; this is almost definitely now conflicting in some way with _Widget's. The line that throws this error *used* to call this.attr, but now because of the attr -> get/set switch in 1.5, it's calling get - but since _Grid and its subclasses already define their own get method, this throws a wrench into the works.

There are probably a number of other places where this kind of conflict could cause trouble in the grid classes; to add to the problem, get was already a public method in DataGrid as well, so I'm not sure what would be the right answer to resolving this.

Change History (3)

comment:1 Changed 9 years ago by bill

Milestone: tbd1.5
Owner: changed from bryanforbes to kriszyp
Summary: dojox grid classes: get method collisions in 1.5?[regression] dojox grid classes: get method collisions in 1.5?

Reassigning to Kris, who did that get/set code in _Widget and tried to patch up grid to work.

comment:2 Changed 9 years ago by Adam Peller

Owner: changed from kriszyp to Kris Zyp

comment:3 Changed 9 years ago by Kris Zyp

Resolution: fixed
Status: newclosed

(In [22447]) Removes this.get = null, fixes #11385 !strict

Note: See TracTickets for help on using tickets.