Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11379 closed defect (fixed)

Commit [22387] breaks ContentPane

Reported by: Brett van de Sande Owned by:
Priority: high Milestone: 1.5
Component: Dijit Version: 1.5.0b2
Keywords: Cc: Brett van de Sande, Ace Sorensen, bill, Mike Wilcox
Blocked By: Blocking:

Description

Commit [22387] breaks ContentPane. This can be seen at:

http://gideon.eas.asu.edu/web-UI-test/index.html?s=54321&u=bvds&p=fluids8&e=

Look at the text input box on the lower right hand corner. You can see the pre-[22387] behavior at:

http://gideon.eas.asu.edu/web-UI/index.html?s=54321&u=bvds&p=fluids8&e=

I will try to create a proper self-contained example of this bug, but it may be a day or two before I get to it.

Attachments (1)

bug.html (4.1 KB) - added by Ace Sorensen 9 years ago.
Cleaner version

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by Brett van de Sande

Bug seen in Firefox 3.6.6 but does not appear in Safari 4.1 or IE 8.

comment:2 Changed 9 years ago by bill

Component: GeneralDijit
Owner: anonymous deleted

Thanks for tracing down the rev number and working on a test case. Are you sure the issue wasn't fixed with [22394]?

Actually I just tried the first link you listed in FF, both mac and PC, and didn't see any weird behavior.

comment:3 Changed 9 years ago by Brett van de Sande

I see an additional problem in some browsers: The blue border across the bottom of the screen is missing in IE 8, Safari 4.1 & 5 on OS X, Safari 4.0.2 on Windows, and Chrome 5.0.375.86.

The extra scrollbar with missing textbox (as reported above) is seen on FF 3.6.6 on OS X.

Everything works fine on FF 3.6.6 on Windows.

comment:4 Changed 9 years ago by Ace Sorensen

Cc: Mike Wilcox added

comment:5 Changed 9 years ago by Brett van de Sande

Yes, it looks like Commit [22394] fixes the bug seen on FF 3.6.6 on OS X. Ace, can you check the other browsers and, assuming they look ok, close this ticket?

comment:6 Changed 9 years ago by Ace Sorensen

Testing with OS X it still doesn't work.

comment:7 Changed 9 years ago by Ace Sorensen

OS X FF 3.6.6

comment:8 Changed 9 years ago by bill

OK, still waiting for a self contained testcase.

Changed 9 years ago by Ace Sorensen

Attachment: bug.html added

Cleaner version

comment:9 Changed 9 years ago by Ace Sorensen

Also the button vs input box size varies between browsers as do their positioning with respect to their containers. Firefox 3.6.6 for OS X seems to be the only one that thinks they are two big for their contentPane though.

comment:10 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

Asaelh, thanks for the test case. I see some unwanted scrollbars in the bottom right showing up on FF3.6.6/mac although not sure it's a dojo bug. The problem is that your inner BorderContainer (id="helpWrapPane") doesn't have any width specified.

I can see that you want bottom-up sizing where the width of the input + button determines the inner BorderContainer's width, which determines the ExpandoPane's width. Dijit just doesn't support that. Would be nice and swing-like if it did.

I'm going to mark this as fixed since I think, even if that example code was working before [22387], it was just a fluke. Pluswhich the testcase you supplied is different than the original reported problem, which was fixed in [22394].

comment:11 Changed 9 years ago by bill

Milestone: tbd1.5
Note: See TracTickets for help on using tickets.