Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11378 closed defect (fixed)

IE, dojo.query("> [widgetId]") fail on page unloading

Reported by: virsir Owned by: anonymous
Priority: high Milestone: 1.5
Component: Core Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description

IE throws an exception "'undefined' is null or not an object". It occurs when I tried to refresh my page and dojo tried to to use dojo.query("> [widgetId]") to destroy all widgets in that time.

query.js line876:
var te, x = 0, tret = root[childNodesName];
while(tr = tret [x++]) exception here as tret is undefined.

I am not very sure why this would happen, it may be caused by double destroy, but it should be better if there is a check against the variable tret.

Change History (2)

comment:1 Changed 9 years ago by bill

Milestone: tbd1.5
Resolution: fixed
Status: newclosed

There's no such query in dojo 1.5, it was removed in [22269]. If you are still seeing a problem with the latest code please attach a test case using the attach file button, and then reopen the ticket.

comment:2 Changed 9 years ago by virsir

The ticket #7345 seems described the same problem.

Note: See TracTickets for help on using tickets.