Opened 9 years ago

Closed 7 years ago

Last modified 4 years ago

#11366 closed enhancement (fixed)

Add option for labelled values on all chart plot types

Reported by: Chris Mitchell Owned by: cjolif
Priority: high Milestone: 1.9
Component: Charting Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description

Pie chart has the option to position labels inside slices, but appears to be the only chart type that has label support.

It's common to want to show labels for chart series values for any chart type, esp. Column,Bar,Scatter,Line. We should consider this as a common feature.

For chart types with, properties are needed to specify location of the label, eg. inside/outside area, padding, alignment.

Attachments (2)

11366.patch (20.0 KB) - added by cjolif 7 years ago.
first draft of patch to add labels on most plots that are missing them
11366 (2).patch (24.6 KB) - added by cjolif 7 years ago.
revised patch with some fixes + use in test sample

Download all attachments as: .zip

Change History (15)

comment:1 Changed 9 years ago by Eugene Lazutkin

Milestone: tbdfuture
Status: newassigned

comment:2 Changed 7 years ago by cjolif

Cc: cjolif added
Owner: changed from Eugene Lazutkin to cjolif

comment:3 Changed 7 years ago by cjolif

#13403 is a duplicate of this ticket.

comment:4 Changed 7 years ago by cjolif

Milestone: future1.9

tentative for 1.9

Changed 7 years ago by cjolif

Attachment: 11366.patch added

first draft of patch to add labels on most plots that are missing them

comment:5 Changed 7 years ago by cjolif

Cc: cjolif removed

Note that pointing the mouse on the labels, prevents the columns to receive highlight or tooltip... I will come up with a workaround but having pointerEvents support in gfx (see #16370) would help.

Changed 7 years ago by cjolif

Attachment: 11366 (2).patch added

revised patch with some fixes + use in test sample

comment:6 Changed 7 years ago by cjolif

In [30030]:

refs #11366. Implements labelling for Bubble/Columns/Default/Scatter?.

comment:7 Changed 7 years ago by cjolif

Resolution: fixed
Status: assignedclosed

comment:8 Changed 7 years ago by cjolif

In [30093]:

refs #11366. Fix issues with marker box.

comment:9 Changed 7 years ago by bill

In [30102]:

fix syntax error from [30030] that breaks doc parser, refs #11366

comment:10 Changed 7 years ago by cjolif

In [30273]:

refs #11366. Fix regression on v/hAxis positioning in markup as well as some space/tab issues

comment:11 Changed 6 years ago by cjolif

In [30689]:

refs #11366. Fix regression on test_missingpoints.html introduced by [30030].

comment:12 Changed 4 years ago by subhajitbhuiya

Can you please provide an example where individual bar is showing label / number? Which property to set for that.

comment:13 Changed 4 years ago by cjolif

See in test_chart2d-amd.html, chart #24 (Clustered columns, custom axes, custom strokes, fills, and gap.), it is just setting labels: true property on the series.

Note: See TracTickets for help on using tickets.