Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#11364 closed defect (fixed)

[regression] ComboBox: wrong horizontal positioning when scrolled

Reported by: googie Owned by: bill
Priority: high Milestone: 1.5
Component: Dijit - Form Version: 1.4.3
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Problem appears when a page is wider than the screen and horizontal scrollbar is present. If we scroll a page and then click the combobox, the options container is mispositioned. It looks as if it's still in the same place as it was when no scroll was performed - doesn't take scrollLeft into consideration.

ComboBox is positioned well vertically though.

Change History (6)

comment:1 Changed 9 years ago by googie

Issue similar to http://bugs.dojotoolkit.org/ticket/10581 although seems a bit different, that's why it's been created.

comment:2 Changed 9 years ago by googie

Sorry - wrong component in the ticket chosen. Should be "Dijit" instead of DojoX Form. I cannot find an option to edit bug description, that's why I post this as a comment.

comment:3 Changed 9 years ago by bill

Component: DojoX FormDijit
Description: modified (diff)
Owner: dante deleted
Summary: ComboBox - wrong horizontal positioning when scrolledComboBox: wrong horizontal positioning when scrolled

Agreed, it's a different issue. I wonder if the problem is with dojo.position() or something specific to the dijit.popup/dijit.place code.

comment:4 Changed 9 years ago by bill

Milestone: tbd1.5
Owner: set to bill
Status: newassigned
Summary: ComboBox: wrong horizontal positioning when scrolled[regression] ComboBox: wrong horizontal positioning when scrolled

I was able to reproduce by adding this to _autoComplete.html:

<nowrap>ABCEFGHIJKLMONPQRSTUVWXYZABCEFGHIJKLMONPQRSTUVWXYZABCEFGHIJKLMONPQRSTUVWXYZABCEFGHIJKLMONPQRSTUVWXYZABCEFGHIJKLMONPQRSTUVWXYZABCEFGHIJKLMONPQRSTUVWXYZABCEFGHIJKLMONPQRSTUVWXYZABCEFGHIJKLMONPQRSTUVWXYZ</nowrap>

It's a regression, starting in 1.4.1, from #10581. I'll fix.

comment:5 Changed 9 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [22393]) Fix ComboBox drop down positioning problem when:

  1. the drop down's width has been increased to match the width of the ComboBox
  2. the page has a horizontal scrollbar, and has been scrolled

There's still an issue on IE8 in RTL mode though, listed in #11376.

Fixes #11364, refs #10581, #11376.

comment:6 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.