Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11358 closed defect (fixed)

[regression] ColorPalette colors don't match up with their borders well when used with other widgets.

Reported by: jason_hays22 Owned by: bill
Priority: high Milestone: 1.5
Component: Dijit Version: 1.5.0b2
Keywords: GSoC Cc: Karl Tiedt, Douglas Hays
Blocked By: Blocking:

Description (last modified by bill)

While using the DropDownButton, TooltipDialog, and ColorPalette widgets together, some of the focus borders, which are supposed to go around the colors, don't fit very well. As you go to the right, they become less and less aligned.

Tested with IE6 and IE8 (emulating IE7 only). Safari 5 and Firefox 3.6 work fine.

Attachments (2)

ColorPaletteScreen.jpg (43.4 KB) - added by jason_hays22 10 years ago.
defect_ColorPalette.html (869 bytes) - added by jason_hays22 10 years ago.
(test case) I ran this from dojox\widget\tests

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by jason_hays22

Attachment: ColorPaletteScreen.jpg added

comment:1 Changed 10 years ago by Douglas Hays

Owner: set to bill

Changed 10 years ago by jason_hays22

Attachment: defect_ColorPalette.html added

(test case) I ran this from dojox\widget\tests

comment:2 Changed 10 years ago by bill

Description: modified (diff)

Ouch, thanks for the test case. Looks like the padding: 8px setting on the dijitTooltipContainer causes the rendering problem, presumably due to some IE bug. Although a plain <div style="padding: 8px"> wrapper around a ColorPalette works.

I'd like to fix this for 1.5 although not sure how.

comment:3 Changed 10 years ago by bill

Milestone: tbd1.5
Status: newassigned
Summary: ColorPalette colors don't match up with their borders well when used with other widgets.[regression] ColorPalette colors don't match up with their borders well when used with other widgets.

comment:4 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [22390]) Fix horizontal spacing of ColorPalette cells. Problem was that the width: 20px isn't obeyed on IE/quirks when the ColorPalette is inside a TooltipDialog. Fixes #11358.

comment:5 Changed 10 years ago by bill

(In [22391]) Oops, [22390] overwrote a previous change, adding back in. Refs #11358.

Note: See TracTickets for help on using tickets.