Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11313 closed defect (fixed)

[regression] FilteringSelect: pasted item or first keyed char shows invalid on first entry

Reported by: eescobar Owned by: Douglas Hays
Priority: high Milestone: 1.5
Component: Dijit - Form Version: 1.4.1
Keywords: FilteringSelect Cc: edgar_escobar@…
Blocked By: Blocking:

Description (last modified by bill)

Before Dojo 1.4.1 and after dojo 1.1.1 it was possible to paste or start typing a value in a FilteringSelect dijit in the pasted value or keyed in characters would not cause the dijit to show up in an invalid state.

Now it seems that that is not the case.

Steps to reproduce:

  1. Create a datastore
  2. Create a FilteringSelect dijit and assign it the new created store.
  3. Load the page

You will notice that right after you type a character in the FilteringSelect that the dijit goes into a invalid state then into a valid one. This also happens if you paste into the dijit using ctrl+v. This seems to only happen the first time you paste into the dijit. If you have previous clicked into or tabbed into a dijit and then pasted another valid value into it or start to key in a valid character, the new valid value doesn't show as being in an invalid state.

Shouldn't this work as the opposite? So that when you start to key in text or paste the text, that the text shows up as valid and then after the fetch gets execute, if the item isn't found then show it as invalid.

I have attached a file to demonstrate the issue.

You can type the letter “N” in the orgState dijit after loading the page and you can see it turn yellow before showing the dropdown list.

Attachments (2)

dojoFilteringSelect.html (2.4 KB) - added by eescobar 9 years ago.
11313.patch (584 bytes) - added by Douglas Hays 9 years ago.
patch against 1.5 trunk - needs verification

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by eescobar

Attachment: dojoFilteringSelect.html added

comment:1 Changed 9 years ago by Douglas Hays

Owner: set to Douglas Hays

Changed 9 years ago by Douglas Hays

Attachment: 11313.patch added

patch against 1.5 trunk - needs verification

comment:2 Changed 9 years ago by Douglas Hays

Milestone: tbd1.5.1
Status: newassigned

Please test the attached patch to check for regressions. The same fix should work on 1.4.

comment:3 Changed 9 years ago by Douglas Hays

Summary: FiileringSelect pasted item or first keyed char shows invalid on first entry[regression] FiileringSelect pasted item or first keyed char shows invalid on first entry

comment:4 Changed 9 years ago by eescobar

We tried the patch in our version of Dojo (1.4.1) on IE6 SP3 and FF 3.6 and it worked fine for us. This has been one of the first of 2 issues that I have logged and they have both been fixed within a sort amount of time. Thanks for the patches and quick turn around time.

comment:5 Changed 9 years ago by bill

Description: modified (diff)
Summary: [regression] FiileringSelect pasted item or first keyed char shows invalid on first entry[regression] FilteringSelect: pasted item or first keyed char shows invalid on first entry

comment:6 Changed 9 years ago by bill

Milestone: 1.5.11.5

Moving this back to 1.5 since rc1 is clearly is being treated as a beta.

comment:7 Changed 9 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [22361]) Fixes #11313. Don't validate a FilteringSelect? if a search is in progress since it'll be validated on return.

comment:8 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.