Opened 9 years ago

Closed 8 years ago

#11310 closed defect (worksforme)

setStore datagrid memory leak in IE

Reported by: ancaa Owned by: Bryan Forbes
Priority: high Milestone: 1.7
Component: DojoX Grid Version: 1.4.3
Keywords: Cc:
Blocked By: Blocking:

Description

I have some problems when I make setStore. In FF everything works oky.

First it was something like this:

var store = aGrid.store;
store._getItemsFromLoadedData(newGridContent);
aGrid.setStore( store);

In IE7, memory is growing fast 2,3 M per second.

After that, I have changed with:

aGrid.store.close();
aGrid.setStore(new dojo.data.ItemFileReadStore(
		                           {data:newGridContent,
		                          urlPreventCache: true}));

And the same problem.

Any idea why in 1 hour, the memory of the IE process rich 1,5 M? I make refresh after 5 seconds on my grid.

Attachments (1)

11310.zip (16.3 KB) - added by evan 8 years ago.
Test repeating setStore() based on http://www.sitepen.com/labs/code/grid/new_grid_features.tar.gz

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by ancaa

I have made debugging on method setStore and I saw that in method adaptWidth (called by _resize), this.views.onEach("adaptWidth"); fires "onresize" window:

dojo.connect(window, "onresize", grid, function() {
						var mygrid = dijit.byId(grid.id);
						mygrid.resize();
						//mygrid.update();
						console.log("resizeGrid");
					});

What is very strange is that it's only happen in IE7. it makes resize on the grid 5 times in 5 seconds and that's why the memory is growing.

comment:2 Changed 9 years ago by ancaa

adaptWidth resize the window, but only in IE8 with IE8 standards. So it's a bug from explorer?

comment:3 in reply to:  2 Changed 9 years ago by ancaa

AdaptWidth? resize the window, but only in IE7. If I change to IE8 standards, everything works oky. So it's a bug from explorer?

comment:4 Changed 9 years ago by James Burke

Component: GeneralDojoX Grid
Owner: changed from anonymous to bryanforbes

comment:5 Changed 9 years ago by bill

Owner: changed from bryanforbes to Bryan Forbes

comment:6 Changed 8 years ago by evan

Milestone: tbd1.7
Resolution: worksforme
Status: newclosed

Not able to reproduce the resizing issue in IE7 with the attached test case(which is based on the online DataGrid demo), and the memory usage is very stable across all browsers(including IE7).

This might already be fixed with [23534]

Changed 8 years ago by evan

Attachment: 11310.zip added
Note: See TracTickets for help on using tickets.