Opened 9 years ago

Closed 9 years ago

#11308 closed defect (fixed)

[regression] ColorPalette: templateString not well formed

Reported by: cjh Owned by: bill
Priority: high Milestone: 1.5
Component: Dijit Version: 1.5.0b2
Keywords: Cc: jochen.hansmeyer@…
Blocked By: Blocking:

Description (last modified by bill)

templateString not well formed:

templateString: dojo.cache("dijit", "templates/ColorPalette.html", "<div class=\"dijitInline dijitColorPalette\">\n\t<img class=\"dijitColorPaletteUnder\" dojoAttachPoint=\"imageNode\" waiRole=\"presentation\" alt=\"\"/>\n\t<table class=\"dijitPaletteTable\" cellSpacing=0 cellPadding=0>\n\t\t<tbody dojoAttachPoint=\"gridNode\"></tbody>\n\t</table>\n</div>\n")

should be: cellSpacing=\"0\" cellPadding=\"0\">

Change History (6)

comment:1 in reply to:  description Changed 9 years ago by cjh

Problem is in dijit/templates/ColorPalette.html and in dijit/templates/Menu.html

comment:2 Changed 9 years ago by Adam Peller

Milestone: 1.51.6

comment:3 Changed 9 years ago by bill

HTML doesn't require quotation marks around simple values, although of course XML does. Is there a test case that's actually failing for you?

comment:4 in reply to:  3 Changed 9 years ago by cjh

It fails as soon as you use it in a XHTML page. Seems to be the only place in Dojo where the quotation marks are missing !

comment:5 Changed 9 years ago by bill

Description: modified (diff)
Milestone: 1.61.5
Owner: set to bill
Status: newassigned
Summary: templateString not wellformed in ColorPalette[regression] ColorPalette: templateString not well formed

Fair enough, I will update it. Looks like those two attributes were added for 1.5 to support claro.

comment:6 Changed 9 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [22365]) Add quotes around attribute values so it works on XHTML pages, fixes #11308.

Note: See TracTickets for help on using tickets.