Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11293 closed defect (invalid)

[IE7]dijit.form.Button.onClick doesn't trigger if button has css style position:relative

Reported by: legendary Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.3.2
Keywords: position relative dijit.form.Button dijit.scrollIntoView IE7 Cc:
Blocked By: Blocking:

Description

I found a problem with Dojo 1.3.2 and 1.3.3 (not tested with previous versions):
If a button is in relative position and the button is not in the middle of the screen, the page scrolls to see the button (ok with that) but the action is not executed...

I have also seen the problem if the button was in position static but one (or several) of its parent was in position relative. But I can't reproduce it in a simple test page...

This bug only appears on IE7 and if the button and/or one of its parent is in relative position.

See attached file in order to reproduce the bug

I haven't reproduced this bug with Dojo 1.4.3

Our project is currently using Dojo 1.3.2, so is there any fix to apply in order to correct this bug (even if it is temporary) ?

Thanks

Attachments (1)

test.html (3.4 KB) - added by legendary 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by legendary

Attachment: test.html added

comment:1 Changed 9 years ago by legendary

Sorry,

I forgot to fill the title. Can you modify it please ? "dijit.form.Button.onClick doesn't trigger if button has css style position:relative"

comment:2 Changed 9 years ago by Adam Peller

Summary: [1.3.2|1.3.3][IE7][IE7]dijit.form.Button.onClick doesn't trigger if button has css style position:relative

Can you verify if this problem still exists in the latest release (1.5.0rc1)

comment:3 Changed 9 years ago by legendary

it's ok with Dojo 1.5.0rc1 but it seems it is corrected since 1.4 (at least from 1.4.3. Not tested with 1.4.0, 1.4.1 and 1.4.2)

comment:4 Changed 9 years ago by Douglas Hays

Resolution: invalid
Status: newclosed

You should set scrollOnFocus="false" on the BUTTON 1 tag.

comment:5 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.