Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11280 closed defect (fixed)

Repopulating a grid creates error in IE

Reported by: Glenn Williams Owned by: Bryan Forbes
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 0.3.1
Keywords: grid ie focus _view Cc:
Blocked By: Blocking:

Description

The attached file reproduces the error.

If a grid is contained and used within a dialog, there is a scenario in which a row cannot be selected on the grid. ONLY IN IE 7-8.

To replicate put the attached code in the dojox.tests directory. The code can self reference back to Dojo from there.

Press the button on the page to open the dialog, then press the search button.You'll get a list of items in the grid. Select a value from the list and notice the "Select" button at the bottom of the screen becomes enabled( onRowSelect).

Press the search button again. You'll get a much smaller list and this is where the issue is. Select a value from the list. You'll get an error in IE.

Press the button to get back to the larger list, and select a row. All is well.Until you press the search button again. It seems that a list of values smaller than the visible number of rows in the grid breaks selection.

This is the error returned in IE:

Unexpected call to method or property access.(line 76)(eval code)

In this file _View.js at this line:

focus: function(){

if(dojo.isWebKit
dojo.isOpera){

this.hiddenFocusNode.focus();

}else{

this.scrollboxNode.focus();

}

},

Attachments (1)

trav_grid_error.html (20.4 KB) - added by Glenn Williams 9 years ago.
Test page that can be run from Dojox tests

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by Glenn Williams

Attachment: trav_grid_error.html added

Test page that can be run from Dojox tests

comment:1 Changed 9 years ago by bill

Owner: changed from bryanforbes to Bryan Forbes

comment:2 Changed 9 years ago by Evan

Resolution: fixed
Status: newclosed

(In [23618]) Fixes #11280 , by making sure _FocusManager.focusView always exists

comment:3 Changed 9 years ago by evan

Milestone: tbd1.6
Note: See TracTickets for help on using tickets.