Opened 9 years ago

Closed 9 years ago

#11276 closed defect (worksforme)

Axis labels not displaying in IE8 with 1.4.3

Reported by: HS Owned by: Eugene Lazutkin
Priority: high Milestone: 1.5
Component: Charting Version: 1.4.3
Keywords: IE8, axis labels Cc:
Blocked By: Blocking:

Description

Axis labels are not displaying in IE8 when using Dojo 1.4. The sample code below properly displays legends either using IE8 with Dojo 1.3 or using FireFox? with Dojo 1.3 or 1.4. The problem is only with the combination of IE8 and Dojo 1.4.

var chart1 = new dojox.charting.Chart2D("simplechart");
chart1.addPlot("default", {type: "Lines"});
chart1.addAxis("x");
chart1.addAxis("y", {vertical: true});
chart1.addSeries("Series 1", [1, 2, 2, 3, 4, 5, 5, 7]);
chart1.render();

Change History (4)

comment:1 Changed 9 years ago by Adam Peller

Component: DojoxCharting
Owner: changed from Adam Peller to Eugene Lazutkin

Could you confirm this with the latest 1.5 beta release?

comment:2 Changed 9 years ago by Eugene Lazutkin

Status: newassigned

Works for me, but I'll retest.

comment:3 Changed 9 years ago by Eugene Lazutkin

Milestone: tbd1.5

comment:4 Changed 9 years ago by Eugene Lazutkin

Resolution: worksforme
Status: assignedclosed

Works for me with the current codebase. Please retest and reopen with a simple test case, if you still see the problem.

Note: See TracTickets for help on using tickets.