Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11265 closed defect (fixed)

[regression] TooltipDialog: doesn't get focus on mouse click of DropDownButton

Reported by: David Schwartz Owned by: bill
Priority: high Milestone: 1.5.1
Component: Dijit - LnF Version: 1.5.0b2
Keywords: ibm toolbar accessibility keyboard focus Cc: bill
Blocked By: Blocking:

Description

The behavior of the keyboard focus currently varies with the technique used to select the toolbar item. Consider the editor tab on http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/themes/themeTester.html?theme=claro. Placing the focus in the toolbar, cursoring over to the Create link item and then using SPACE to select results in the associated tooltipdialog being displayed with the focus in the first field. However, simply clicking on the toolbar item results in the tooltipdialog being displayed but the toolbar item retains the keyboard focus while the first field is in error (the field being in error from the start is yet a different problem). The attached gif illustrates the difference in behavior.

REGARDLESS of the selection technique, the resulting behavior should be the same. The focus should be placed in the appropriate (note, not always the first) field in the dialog; it should not be in the toolbar.

I'm assuming this is a toolbar issue.

Attachments (1)

tooltipdialog.gif (21.4 KB) - added by David Schwartz 9 years ago.
video of the difference

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by David Schwartz

Attachment: tooltipdialog.gif added

video of the difference

comment:1 Changed 9 years ago by bill

Owner: set to bill
Status: newassigned

Agreed. It's an issue with any DropDownButton, regardless of whether it's in a toolbar or not.

comment:2 Changed 9 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [22672]) Fix TooltipDialog so it gets focus when opened from a mouse click (on a DropDownButton) in addition to a keyboard "click", fixes #11265 !strict.

comment:3 Changed 9 years ago by bill

Milestone: 1.61.5.1
Summary: TooltipDialog and Toolbar focus behavior inconsistent[regression] TooltipDialog: doesn't get focus on mouse click of DropDownButton

As #11616 pointed out, this worked in 1.4 and broke in 1.5 (and then I fixed it in [22672] above). I guess I should backport the fix to 1.5.

comment:4 Changed 9 years ago by bill

(In [22749]) Backport [22672] (focus TooltipDialog on DropDownButton mouse click) to 1.5/ branch, since it's a 1.5/ regression. Refs #11265 !strict.

Note: See TracTickets for help on using tickets.