Opened 9 years ago

Closed 9 years ago

#11234 closed defect (fixed)

dojox.widget.Standby does not hide panels contained in a borderContainer

Reported by: Jean-Rubin Leonard Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.5
Component: DojoX Widgets Version: 1.5.0b2
Keywords: Standby bordercontainer z-index Cc:
Blocked By: Blocking:

Description

Hi, there's an issue with the dojox.widget.Standby where the overlay does not cover the content pane widget it's been assigned to cover. The target is assigned to the domNode of a contentPane and when I inspect the target with firebug, the right domNode is highlighted. I believe however that there's some issue in the Zindex that causes the underlay to be below the pane which we are trying to hide. I am on firefox 3.6.3 on Mac OS and I am running from trunks. I have attached a test case where the issue is reproduced. JR

Attachments (3)

standbyBC.html (2.3 KB) - added by Jean-Rubin Leonard 9 years ago.
standbyBC.2.html (2.3 KB) - added by Jared Jurkiewicz 9 years ago.
Showing setting of zIndex to overlay ABS/zIndex'ed nodes
Standby_zIndexCalc.patch (942 bytes) - added by Jared Jurkiewicz 9 years ago.
Patch to look up the containing chain to see if there are zIndexes to overlay, improved 'auto' handling.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by Jean-Rubin Leonard

Attachment: standbyBC.html added

Changed 9 years ago by Jared Jurkiewicz

Attachment: standbyBC.2.html added

Showing setting of zIndex to overlay ABS/zIndex'ed nodes

comment:1 Changed 9 years ago by Jared Jurkiewicz

Resolution: invalid
Status: newclosed

You need to set the zIndex of the Standby overlay to the level you want it at. Its default is auto.

In this case you need to set it higher, such as 100.

The zIndex is explicitly called out in the documentation as user configurable. See: http://docs.dojocampus.org/dojox/widget/Standby

Attached modified form of testcase showing it working once you configure the zIndex.

User error.

comment:2 Changed 9 years ago by Jared Jurkiewicz

And by the way, you're not supposed to set width/height on 'center' regions. The bordercontainer calculates center regions and sizes them to fill the remaining space. By setting width/height, it tends to screw it up.

comment:3 Changed 9 years ago by bill

BTW, BorderContainer currently sets the ContentPanes at z-index:2 and the splitters at z-index: 10. That could almost definitely be changed to remove the ContentPane's z-index settings, and set the splitters' z-index: 1.

Maybe even the splitters' z-index setting can be removed... IIRC it was fixing a rendering glitch where the borders of the splitters weren't visible, but nowadays the borders are on the ContentPane itself.

Changed 9 years ago by Jared Jurkiewicz

Attachment: Standby_zIndexCalc.patch added

Patch to look up the containing chain to see if there are zIndexes to overlay, improved 'auto' handling.

comment:4 Changed 9 years ago by Jared Jurkiewicz

Milestone: tbd1.5
Resolution: invalid
Status: closedreopened

Looks like the zIndex calcing can be improved. Reopening.

comment:5 Changed 9 years ago by Jared Jurkiewicz

Owner: changed from dante to Jared Jurkiewicz
Status: reopenednew

comment:6 Changed 9 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [22282]) Minor improvement to zIndex calculations. fixes #11234

Note: See TracTickets for help on using tickets.