Opened 9 years ago

Closed 5 years ago

Last modified 5 years ago

#11200 closed defect (fixed)

dojo/tests/_base/html_docScroll.html::t::testSpeed failure (IE8)

Reported by: bill Owned by: Eugene Lazutkin
Priority: low Milestone: 2.0
Component: HTML Version: 1.5.0b2
Keywords: dohfail Cc: dgurney@…
Blocked By: Blocking:

Description (last modified by bill)

To reproduce:

  1. start IE8

Optional steps:

  1. press F12 to get developer console
  2. select "Console" tab

Mandatory step:

  1. load dojo/tests/runTests.html

This gets a failure on:

../../dojo/tests/_base/html_docScroll.html::t::testSpeed

It only happens when the developer console is started, and console is selected, so not sure if there's a real bug or not. Would be nice to avoid the test failure.

Change History (19)

comment:1 Changed 9 years ago by James Burke

Milestone: tbd1.6
Owner: changed from sjmiles to James Burke

comment:2 Changed 8 years ago by bill

Milestone: 1.6future

(sadly) punting seemingly abandoned ticket and meta tickets to future

comment:3 Changed 8 years ago by bill

Keywords: dohfail added

comment:4 Changed 8 years ago by bill

Description: modified (diff)
Keywords: dohfail removed
Summary: dojo/tests/_base/html_docScroll.html::t::testSpeed failuredojo/tests/_base/html_docScroll.html::t::testSpeed failure (IE8)

This is now failing for me even when the console isn't running, even on a fresh start of IE8. (I'm still testing it through runTests.html.) I'm going to comment out the test until it's fixed, and remove the dohfail keyword since I'm not sure this test ever worked.

comment:5 Changed 8 years ago by bill

Milestone: futuretbd
Owner: changed from James Burke to Douglas Hays

comment:6 Changed 8 years ago by bill

In [26144]:

disable testSpeed() test until it passes on IE8, refs #9617, #11200.

comment:7 Changed 8 years ago by Douglas Hays

Milestone: tbd1.7
Owner: changed from Douglas Hays to Eugene Lazutkin
Priority: normalhigh

I'm not sure it's a good practice to hide these failures. Dojo 1.7's docScroll takes twice as long as 1.6's version and the testcase was telling us that. I think that counts as a regression.

comment:8 Changed 8 years ago by bill

Cc: dgurney@… added

Good catch, I'll reenable the test. The performance regression started in [25705], not sure why.

comment:9 Changed 8 years ago by bill

In [26154]:

re-enable testSpeed() test, the IE8 failure is a regression, refs #9617, #11200.

comment:10 Changed 8 years ago by bill

Keywords: dohfail added

comment:11 Changed 8 years ago by Douglas Hays

On IE8, all the lost time seems to be contributable to

var doc = win.doc, node = doc.parentWindow || doc.defaultView;

taking a very long time to execute while dojo.global is very fast. The addition of has('quirks') and win.body() seems to have had minimal effect.
(I added the var doc to try and make it a bit faster but it had no effect on IE8)

comment:12 Changed 7 years ago by Chris Mitchell

Priority: highnormal

comment:13 Changed 7 years ago by Chris Mitchell

This does not affect end users, only devs that happen to have console open during test automation. Reducing priority to normal, non-blocking for rc1

comment:14 Changed 7 years ago by bill

As I mentioned above, this fails even when the console isn't running, even on a fresh start of IE8. (I'm still testing it through runTests.html.) Therefore it does affect end users, although not sure how much.

comment:15 Changed 7 years ago by Eugene Lazutkin

Priority: highlow

comment:16 Changed 7 years ago by Colin Snover

Milestone: 1.82.0

1.8 has been tagged; moving all outstanding tickets to next major release milestone.

comment:17 Changed 5 years ago by Colin Snover <github.com@…>

Resolution: fixed
Status: newclosed

In a3dd7a47aa01315e601525b0d8217a8408237149/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:18 Changed 5 years ago by Colin Snover <github.com@…>

In 8f0bc13822c4ed0a55e079d9df6b987bd6088763/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:19 Changed 5 years ago by mahays0 <mahays0@…>

In d7ec9bb2e84a0880e831b5c120214011cdcd9097/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.