Opened 9 years ago

Closed 9 years ago

#11179 closed defect (fixed)

Menu: IE high contrast focus box missing

Reported by: haysmark Owned by: bill
Priority: high Milestone: 1.5
Component: Dijit Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description

You can also see this in a11y mode:

http://archive.dojotoolkit.org/nightly/checkout/dijit/themes/themeTesterQuirk.html?theme=claro&dir=rtl&a11y=true

Open a menu and move your mouse over the items. In IE8, you will not be able to tell which item you have focused. In other browsers, you see an outline around the label itself.

Change History (3)

comment:1 Changed 9 years ago by bill

Milestone: tbd1.5
Status: newassigned
Summary: IE8 menu high contrast focus box missingMenu: IE high contrast focus box missing

The problem also affects keyboard users (which is worse since mouse users can just look at where the cursor is).

I see the problem on IE7 as well as IE8 quirks mode, both in LTR.

comment:2 Changed 9 years ago by bill

PS: although, I don't see the problem in real high-contrast mode, just a11y=true mode. The problem is that the border is defined as white (#fff). I'll change it to black.

comment:3 Changed 9 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [22208]) Make border show up in a11y=true mode, fixes #11179.

Note: See TracTickets for help on using tickets.