Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#11174 closed defect (fixed)

[regression] ComboBox/NumberSpinner: arrows cut off in high contrast (FF3)

Reported by: haysmark Owned by: Douglas Hays
Priority: high Milestone: 1.5
Component: Dijit - Form Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

See:

http://archive.dojotoolkit.org/nightly/checkout/dijit/themes/themeTesterQuirk.html?theme=claro&dir=rtl

In high contrast, click the Select widgets tab. The ComboBox buttons are cut off. Similarly, NumberSpinner buttons are cut off. The cut is vertical, unlike the usual problem where the cut is horizontal.

Change History (7)

comment:1 Changed 10 years ago by haysmark

Description: modified (diff)
Summary: ComboBox buttons cut off in high contrastFF3 buttons cut off in high contrast

comment:2 Changed 10 years ago by bill

Description: modified (diff)
Milestone: tbd1.5
Owner: changed from bill to Douglas Hays
Summary: FF3 buttons cut off in high contrast[regression] FF3 buttons cut off in high contrast

From

.dijit_a11y input.dijitValidationInner, .dijit_a11y input.dijitArrowButtonInner  {
    text-indent:0 !important;
    width:1em !important;
}

comment:3 Changed 10 years ago by bill

Summary: [regression] FF3 buttons cut off in high contrast[regression] ComboBox/NumberSpinner: arrows cut off in high contrast (FF3)

comment:4 Changed 10 years ago by bill

PS: presumably this is because of the FF bug where the <input> shows a border even though we set border:0.

comment:5 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [22205]) Fixes #11174. Firefox needs an extra push to really reset an elements style in high-contrast.

comment:6 Changed 9 years ago by Adam Peller

(In [22844]) Fix typo on 1.5 branch. Fixes #11695, Refs #11174

comment:7 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.