Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11159 closed defect (fixed)

TabContainer: no icons on left/right/menu buttons (IE6/high contrast/RTL)

Reported by: bill Owned by: bill
Priority: high Milestone: 1.5
Component: Dijit Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

To reproduce:

  1. Set Windows to run in high-contrast mode
  2. load themeTester.html?dir=rtl on IE6
  3. make window small enough to see left/right/menu scroll buttons on TabContainer

The "icons" in those buttons appear as boxes, not as arrows.

Change History (6)

comment:1 Changed 9 years ago by bill

Description: modified (diff)

comment:2 Changed 9 years ago by bill

Description: modified (diff)
Summary: Claro TabContainer: no icons on left/right/menu buttons (IE6/RTL/HC)Claro TabContainer: no icons on left/right/menu buttons (IE6/high contrast)

comment:3 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [22188]) Use arrow characters (for high contrast mode) that display correctly on IE6.

Also removing some hardcoded widths that were cutting of the arrow characters in high contrast mode (due to the large font size). My tests show those hardcoded widths are unnecessary, despite the comment that in the CSS files that floats need a hardcoded width.

Fixes #11159.

comment:4 Changed 9 years ago by bill

Description: modified (diff)
Resolution: fixed
Status: closedreopened
Summary: Claro TabContainer: no icons on left/right/menu buttons (IE6/high contrast)TabContainer: no icons on left/right/menu buttons (IE6/high contrast/RTL)

Oops, that didn't fix it. Turns out the problem is only in RTL mode (no idea why).

comment:5 Changed 9 years ago by bill

Resolution: fixed
Status: reopenedclosed

(In [22192]) Second try to fix font problem on IE6 RTL high-contrast mode, for left/right/menu buttons on scrolling TabController, fixes #11159.

comment:6 Changed 9 years ago by bill

(In [22195]) All themes should define width of the arrow icons (not just height), not sure how this was working before. Refs #11159.

Note: See TracTickets for help on using tickets.