Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#11155 closed defect (fixed)

TabContainer: clicking scroll left/right buttons gives them focus (FF)

Reported by: bill Owned by: bill
Priority: high Milestone: 1.6
Component: Dijit Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description

On FF try clicking the scroll-right button on the scrolling tabs. It gets focus on FF. IE doesn't get focus.

This is different behavior than 1.4 although maybe it doesn't matter much either way since it doesn't affect keyboard users.

The node getting focus is

<div id="topTabs_tablist_leftBtn" class="dijitTabInnerDiv" dojoattachpoint="innerDiv,focusNode" wairole="presentation" role="presentation" style="-moz-user-select: none;" aria-disabled="true">

Change History (6)

comment:1 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [22187]) Fix a number of TabContainer issues related to close icon:

  • no [x] text appears in IE7 or IE quirks high-contrast RTL mode (fixes #11153)
  • icon appears on left rather than right in RTL mode
  • hover effect broken in tundra, soria, nihilo (regression from [21144], refs #10613)
  • height problems mixing closable and unclosable tabs on webkit (fixes #11155, !strict):
    • border under unselected tabs also appears under selected tab
    • closable tabs are 1px too tall, obscuring that same border
  • hovering close button in high-contrast mode causes tab to expand horizontally

The main change was to make the close icon a sibling of the label, rather than nested inside of the closeButton span. This avoids browser bugs on webkit and IE. Also stopped using an <img> tag to display the icon since that has issues with the title/alt attributes on IE6/7.

comment:2 Changed 9 years ago by bill

Resolution: fixed
Status: closedreopened

Oops, the above change actually fixes #11156 not #11155, got the numbers confused.

comment:3 Changed 9 years ago by Adam Peller

Milestone: 1.51.6

comment:4 Changed 9 years ago by bill

Resolution: fixed
Status: reopenedclosed

(In [22494]) Avoid unwanted behavior where clicking TabContainer's left/right scroll buttons gives them focus. Fixes #11155.

comment:5 Changed 9 years ago by bill

(In [22789]) Move focus to button before hiding menu, to avoid crash on IE6. Fixes #11658, refs #11155 !strict.

comment:6 Changed 8 years ago by bill

(In [23727]) Don't put border around TabButton close text [x] (shown in high contrast mode instead of icon). It was causing unequal height of tabs. Fixes #11180, refs #11155.

Note: See TracTickets for help on using tickets.