Opened 10 years ago

Closed 10 years ago

#11153 closed defect (fixed)

Claro/RTL: TabContainer: close button not visible IE7 or IE quirks high contrast

Reported by: bill Owned by: bill
Priority: high Milestone: 1.5
Component: Dijit Version: 1.5.0b2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

The close button is not visible when themeTester.html?dir=rtl is run on IE7 or themeTeststerQuirk.html?dir=rtl run on IE, presumably due to this weird rule in claro/layout/TabContainer_rtl.css:

.dj_ie7 .claro .dijitTabRtl .dijitTabCloseText,
.dj_iequirks .claro .dijitTabRtl .dijitTabCloseText {
	width: 0;
	height: 0;
	overflow: hidden;
	float: left;
}

Change History (2)

comment:1 Changed 10 years ago by bill

Description: modified (diff)
Summary: Claro: TabContainer: close button not visible IE7 or IE quirks high contrastClaro/RTL: TabContainer: close button not visible IE7 or IE quirks high contrast

comment:2 Changed 10 years ago by bill

Resolution: fixed
Status: newclosed

(In [22187]) Fix a number of TabContainer issues related to close icon:

  • no [x] text appears in IE7 or IE quirks high-contrast RTL mode (fixes #11153)
  • icon appears on left rather than right in RTL mode
  • hover effect broken in tundra, soria, nihilo (regression from [21144], refs #10613)
  • height problems mixing closable and unclosable tabs on webkit (fixes #11155, !strict):
    • border under unselected tabs also appears under selected tab
    • closable tabs are 1px too tall, obscuring that same border
  • hovering close button in high-contrast mode causes tab to expand horizontally

The main change was to make the close icon a sibling of the label, rather than nested inside of the closeButton span. This avoids browser bugs on webkit and IE. Also stopped using an <img> tag to display the icon since that has issues with the title/alt attributes on IE6/7.

Note: See TracTickets for help on using tickets.