Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#11082 closed defect (fixed)

DropDownButton too tall in quirks mode (FF)

Reported by: bill Owned by: bill
Priority: high Milestone: 1.5
Component: Dijit - Form Version: 1.5.0b1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

See screenshot from themeTesterQuirk.html on FF (not IE, but FF):

This is on tundra theme (actually works correctly in claro).

The height is equal to the height of the ContentPane itself.

Attachments (1)

buttonQuirk.png (10.9 KB) - added by bill 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by bill

Attachment: buttonQuirk.png added

comment:1 Changed 10 years ago by bill

Description: modified (diff)

comment:2 Changed 10 years ago by bill

Description: modified (diff)
Summary: claro: DropDownButton height in quirks mode == surrounding div (FF)DropDownButton too tall in quirks mode (FF)

comment:3 Changed 10 years ago by bill

Owner: set to bill
Status: newassigned

The problem is this code in dijit.css:

.dijitButtonNode .dijitArrowButtonInner {
    ...
    height:100%;
    ...
}

The 100% is currently needed for TextBox widget arrows, but it's harmful for DropDownButton (and it isn't needed since vertical-align: middle does the centering for us there). I'll address this after #11034 is resolved.

comment:4 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [22065]) Limit the height:100% setting on dijitArrowButtonInner to Spinner. It's not needed anywhere else because we use <table> or vertical-align:middle to center the arrow, and it was breaking DropDownButton in quirks mode. Fixes #11082, refs #11003

comment:5 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.