Opened 9 years ago

Closed 9 years ago

#11069 closed defect (fixed)

Menu: clicking away doesn't clear selected state for disabled item

Reported by: bill Owned by: bill
Priority: high Milestone: 1.5
Component: Dijit Version: 1.5.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

In test_Menu.html, click "Disabled" and then click away. Disabled remains blue.

Clicking the disabled item focuses it because for Menu we focus disabled items... and focusing a MenuItem selects it, so that's not a problem. The issue is just clicking away.

Not a regression, this happens in 1.4 too.

Change History (1)

comment:1 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [22019]) this.focusedItem wasn't getting set when clicking a disabled MenuItem, so clicking away wasn't clearing the selected state on the focused item. Fixes #11069 !strict.

Note: See TracTickets for help on using tickets.