Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#11049 closed defect (fixed)

[regression] TextBox: type=file cut off in FF, strange in IE

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 1.5
Component: Dijit - Form Version: 1.5.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

As of [21560] (see #10840), there are problems with type=file TextBox's. The biggest issue is on FF, where the button is cut off:

cut off button on FF

Arguably, there's also an issue with other browsers in the rendering looks a little strange, with the button inside the border:

In trunk on IE:

actual display, on trunk

In 1.4 it looked like:

expected display, on 1.4

Attachments (4)

ff.png (7.2 KB) - added by bill 9 years ago.
cut off button on FF
ie1.4.png (6.1 KB) - added by bill 9 years ago.
expected display, on 1.4
ieTrunk.png (6.3 KB) - added by bill 9 years ago.
actual display, on trunk
11049.patch (1.0 KB) - added by Douglas Hays 9 years ago.
possible fix using a single node template

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by bill

Attachment: ff.png added

cut off button on FF

Changed 9 years ago by bill

Attachment: ie1.4.png added

expected display, on 1.4

Changed 9 years ago by bill

Attachment: ieTrunk.png added

actual display, on trunk

Changed 9 years ago by Douglas Hays

Attachment: 11049.patch added

possible fix using a single node template

comment:1 Changed 9 years ago by Douglas Hays

Bill, please review. I substitute in an alternate template for type=hidden|file OR if templateString="input". The last check is to allow people who are broken with the new template to achieve some level of backward compatibility.

comment:2 Changed 9 years ago by Douglas Hays

Status: newassigned

comment:3 Changed 9 years ago by bill

Seems good.

comment:4 Changed 9 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [22145]) Fixes #11049, #11058. For TextBox? widgets of type file|hidden, swap the multi-node template for a single INPUT version since styling capabilities are only minimally required/allowed. Added the ability to select the single node template (for backward compatibility) by setting templateString="input".

comment:5 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.