Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#11047 closed defect (fixed)

[regression] FilteringSelect: mouse on arrow doesn't open drop down

Reported by: Jared Jurkiewicz Owned by: bill
Priority: blocker Milestone: 1.5
Component: Dijit - Form Version: 1.5.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

REGRESSION: Dropdowns (Font Choice) no longer work via the mouse

Bill,

Load: tests/editor/test_FontChoice.html

Try to click any of the select dropdowns with the mouse. They won't open. The only way to open them is now via the keyboard. This looks like some sort of select/toolbar change? The font choice plugins didn't change.

Change History (5)

comment:1 Changed 9 years ago by Jared Jurkiewicz

I see the same in: dijit/tests/form/_autoComplete.html?testWidget=dijit.form.FilteringSelect?

So seems isolated to the FilteringSelect?.

comment:2 Changed 9 years ago by Jared Jurkiewicz

Component: GeneralDijit
Owner: changed from bill to Douglas Hays
Priority: normalhighest

Doug,

Serious form widget bug. Dropdowns (filtering select, etc, no longer work via the mouse at all. Verified on several machines.)

comment:3 Changed 9 years ago by bill

Owner: changed from Douglas Hays to bill
Status: newassigned
Summary: REGRESSION: Dropdowns (Font Choice) no longer work via the mouse[regression] FilteringSelect: mouse on arrow doesn't open drop down

Yah, good catch, this is fallout from [21960], which in turn was checked in to fix fallout from [21926]. I'm going to roll all of that back as we are going in a different direction, at least for the textbox widgets.

comment:4 Changed 9 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [21998]) Rolling back changes from #10974 and #11029. This amounts to rolling back to [21926] (for the files changed in [21926]) and then adding back [21981] and [21983].

Concerning the goal of #10974, to make it easy to set padding on form input widgets:

  • That will be implemented in the textbox widgets (*TextBox, ComboBox/FilteringSelect, Spinner) in a different way, see #11034.
  • I think likewise for the <table> based widgets, Select and ComboButton, since centering arrows in a <table> should be easy, regardless of padding.
  • As for DropDownButton, not sure, but rolling back that change for now.

!TextBox_sizes.html can be restored to [21938] once #11034 is fixed.

Note that many of the changes in [21926] (and reversions in this check in) were due to changing the clas name dijitArrowButtonInner to dijitArrowButtonImg. For back-compat reasons I'd rather not have a unnecessary CSS name change.

Refs #10974, #11029. Fixes #11047.

comment:5 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.