Opened 9 years ago

Closed 9 years ago

#11039 closed defect (fixed)

[regression] Dojo 1.4 file uploader does not initialize when contained in widgets that do not fire onShow

Reported by: Josh Trutwin Owned by: Mike Wilcox
Priority: high Milestone: 1.5.1
Component: DojoX Uploader Version: 1.4.0
Keywords: File Uploader onShow initialize Cc:
Blocked By: Blocking:

Description

I noticed a change in 1.4 which added the onShow event to _Widget.js, the file uploader in 1.3 used onShow to assume that the uploader was inside a widget such as a Tab Container or Dialog where it was initially hidden. It used the event to initialize Flash when the onShow was fired. With the 1.4 change, all widgets now have an onShow method so any fileUploader in another widget is always connecting it's initialization routines to the parent widget's onShow event. When inside a Content Pane this is ok because the content pane initializes, fires onShow, which triggers the uploader's initialization. When the uploader is in a dijit.form.Form though it never initializes because the form widget doesn't fire onShow. I am guessing there are other containers where this could be a problem?

Possible workaround is to manually fire onShow in an addOnLoad event.

I'm attaching a test case that demonstrates these behaviors.

Thanks!

Attachments (1)

upload_1.4.html (2.2 KB) - added by Josh Trutwin 9 years ago.
Test Scenarios

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by Josh Trutwin

Attachment: upload_1.4.html added

Test Scenarios

comment:1 Changed 9 years ago by bill

Milestone: tbd1.5
Summary: Dojo 1.4 file uploader does not initialize when contained in widgets that do not fire onShow[regression] Dojo 1.4 file uploader does not initialize when contained in widgets that do not fire onShow

Looks like this should be 1.5, since it's a regression.

comment:2 Changed 9 years ago by Adam Peller

Milestone: 1.51.5.1

comment:3 Changed 9 years ago by J Cameron Cooper

See #11760 for a possible effect of this bug.

comment:4 Changed 9 years ago by Mike Wilcox

Resolution: fixed
Status: newclosed

(In [23544]) Fixes #11039 - removed detection of hidden widgets. Note that the FileUploader? will no longer function without help in a node or widget that is initially hidden. Suggested to use dojox.form.Uploader from here out

comment:5 Changed 9 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

Mike,

Please check your fix into the 1.5 branch also. Despite rumors to the contrary, there will be a 1.5.1 release.

comment:6 Changed 9 years ago by Mike Wilcox

Resolution: fixed
Status: reopenedclosed

Changes made as per Adam's request, but it is recommended to now use dojox.form.Uploader.

Note: See TracTickets for help on using tickets.