Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#11033 closed defect (duplicate)

[regression] FilteringSelect validation issue

Reported by: Fausto Lemos Owned by: Douglas Hays
Priority: high Milestone: 1.5
Component: Dijit - Form Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hello guys!

i have a filtering select marked as required. When user types something wrong or leave the filtering blanked the validation works.

But try to leave the filtering empty, click at the arrow to show the result list, and then click outside the filtering. The validation marks the filtering as ok!

this is a know error?

tks!

Change History (8)

comment:1 Changed 9 years ago by bill

It works for me. I tried http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.FilteringSelect, "US State Test 4". I clicked the down arrow icon, and then clicked away, and the field turned yellow.

Can you give steps to reproduce and if it doesn't reproduce on the above link, then attach a test case?

comment:2 in reply to:  1 Changed 9 years ago by Fausto Lemos

Replying to bill:

It works for me. I tried http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.FilteringSelect, "US State Test 4". I clicked the down arrow icon, and then clicked away, and the field turned yellow.

Can you give steps to reproduce and if it doesn't reproduce on the above link, then attach a test case?

Hello Bill!

looking at FilterinSelect? source i discover what is causing this behavior:

_openResultList:function(_4,_5){
                    if(_5.query[this.searchAttr]!=this._lastQuery){
                       return;
                    }
                    this._isvalid=_4.length!=0;
                    this.validate(true);
                    dijit.form.ComboBoxMixin.prototype._openResultList.apply(this,arguments);
                }

the line "this._isvalid=_4.length!=0;" at "_openResultList()" is setting the filtering "_isvalid" is set to "true" just because the filtering has items. This is ok?

tks!

comment:3 Changed 9 years ago by bill

As I said above, you need to give steps to reproduce the problem using either the above link, or a test case that you attach.

comment:4 in reply to:  3 Changed 9 years ago by Thomas Pfeiffer

Replying to bill:

As I said above, you need to give steps to reproduce the problem using either the above link, or a test case that you attach.

Steps to reproduce:

open http://docs.dojocampus.org/dijit/form/FilteringSelect

Version 1.3 should be selected. Append some invalid text to the FilteringSelect? => FilteringSelect? switches state to invalid.

Click somewhere else so it looses focuses. Open the list of the FilteringSelect? => State switches to valid

Do not select anything (select still contains the invalid text) but immediatly click somewhere else so that it looses the focus => State switches back to invalid

Reproduce using Trunk.

Last step fails and State stays valid (same in 1.4 stable).

comment:5 Changed 9 years ago by bill

Owner: set to Douglas Hays
Summary: FilteringSelect validation issue[regression] FilteringSelect validation issue

Thanks, I see that 1.3 is working correctly but trunk is failing.

comment:6 Changed 9 years ago by Douglas Hays

Milestone: tbd1.5
Resolution: duplicate
Status: newclosed

Already fixed in trunk [21276] which means that dojocampus is using a really old trunk build. I suspect dojocampus trunk is really 1.4 since it also doesn't know about the claro theme.

comment:7 in reply to:  6 Changed 9 years ago by Marcus Reimann

Replying to doughays:

Just for your info: As we have learned in the last two weeks, docs.dojocampus.org wasn't updated with 1.4, so the trunk available at docs.dojocampus.org should be a V1.3 trunk (at it is still the same old version, right now).

comment:8 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.