Opened 9 years ago

Closed 9 years ago

#11007 closed defect (fixed)

ondijitclick and _HasDropDown incompatibility

Reported by: bill Owned by: bill
Priority: high Milestone: 1.5
Component: Dijit Version: 1.4.0
Keywords: Cc: Douglas Hays
Blocked By: Blocking:

Description

Putting an ondijitclick handler on a node for a widget that extends _HasDropDown doesn't work. The problem is that ondijitclick calls dojo.stopEvent(e) on the keyDown event:

d.stopEvent(e);		// stop event to prevent scrolling on space key in IE

That stopEvent() is from #3942. It prevents the connect in _HasDropDown from firing:

this.connect(this._buttonNode, "onkeydown", "_onDropDownKeydown");

(Discovered this while working on #11003.)

Change History (1)

comment:1 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [21892]) dojo.stopEvent() prevents dojo.connect()'d handlers from seeing the onkeydown event; use preventDefault() instead. preventDefault() still solves the problem where IE scrolls on space bar. Fixes #11007, refs #3942 !strict.

Note: See TracTickets for help on using tickets.