Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#10992 closed defect (fixed)

FilteringSelect doesn't accept non Javascript identifiers as option values

Reported by: Achim Klotz Owned by:
Priority: high Milestone: 1.5
Component: Dijit - Form Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

In a FilteringSelect? box it's not possible to use option values which contains special characters:

<select dojoType="dijit.form.FilteringSelect">
  <option value="~test1" selected>value 1</option>
  <option value="x[2]">value 2</option>
  <option value="x&5">value 3</option>		
</select>

the reason seems that the values are used as object property names in the html.js line 1475: value = node[propName];

see also the attached test file

Attachments (1)

test_FilteringSelect2.html (1.2 KB) - added by Achim Klotz 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by Achim Klotz

Attachment: test_FilteringSelect2.html added

comment:1 Changed 9 years ago by bill

Milestone: tbd1.5
Resolution: fixed
Status: newclosed

Confirmed this occurs in 1.4, and confirmed that it's fixed in 1.5.

comment:2 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.