Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#10980 closed defect (fixed)

Build Fail

Reported by: youngho Owned by: James Burke
Priority: high Milestone: 1.5
Component: Core Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hello,

I got following build error

[INFO] E:\project\dojo\util\buildscripts>java -Xms256m -Xmx512m -classpath ../shrinksafe/js.jar;../shrinksafe/shrinksafe.jar org.mozilla.javascript.tools.shell.Main build.js action=release profile=standard version=1.5-SNAPSHOT loader=xdomain xdDojoPath=http://mydomain/js/dojo optimize=shrinksafe cssOptimize=comments stripConsole=all
[INFO] release: Using profile: profiles/standard.profile.js
[INFO] release: Using version number: 1.5-SNAPSHOT for the release.
[INFO] release: Deleting: ../../release/dojo
[INFO] release: Copying: ../../dojo/../dijit to: ../../release/dojo/dijit
[INFO] release: Copying: ../../dojo/../dojox to: ../../release/dojo/dojox
[INFO] release: Copying: ../../dojo to: ../../release/dojo/dojo
[INFO] release: Building dojo.js and layer files
[INFO] error loading uri: ./../../release/dojo/dojo/_base/declare.js, exception: TypeError?: Cannot call method "split" of undefined

Attachments (1)

console.html (372 bytes) - added by Eugene Lazutkin 9 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 9 years ago by bill

Component: GeneralCore
Milestone: tbd1.5
Owner: changed from anonymous to Eugene Lazutkin

Assuming this was caused by the recent changes to declare.

comment:2 Changed 9 years ago by Eugene Lazutkin

Owner: changed from Eugene Lazutkin to James Burke

Hmm, declare doesn't use split at all. Is it really called by Rhino? Reassigning to James to look at.

comment:3 Changed 9 years ago by Eugene Lazutkin

Heh. somehow missed my previous post --- recreating + updating it with more info.

Something is wrong. And as far as I can tell it manifests itself in the XD loader. I got a similar error with "debugAtAllCosts". The offending line is 279 in the loader:

TypeError: modulename is undefined
[Break on this error] var syms = modulename.split(".");\n

I am attaching my test file (it is a minimal file, which does nothing but loads Dojo).

Changed 9 years ago by Eugene Lazutkin

Attachment: console.html added

comment:4 Changed 9 years ago by James Burke

Resolution: fixed
Status: newclosed

(In [21809]) Fixes #10980, build and xd loader choke on the dojo.require() reference, even though it is in a string. the regexps used for the build/xd loader are string-aware. Technically not dojo.declare fault, but this is the easiest fix. \!strict

comment:5 Changed 9 years ago by Eugene Lazutkin

:-D

Note: See TracTickets for help on using tickets.