Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1097 closed defect (duplicate)

Setting <body onload="function"> prevents dojo from loading

Reported by: sol@… Owned by: anonymous
Priority: high Milestone:
Component: Core Version: 0.3
Keywords: body onload init Cc:
Blocked By: Blocking:

Description

<body onload="function"> is often used to run init code when page is loaded. I know there's dojo.addOnLoad, but still... Setting <body onload> shouldn't prevent dojo from working correctly. This goes against usability (it's too easy to break the dojo and not even realize why it's broken).

There are methods like addEventListener to prevent possible conflicting situations like this.

Change History (4)

comment:1 Changed 13 years ago by alex

We realize that this is a problem, but the solutions are not nearly as straightforward as you suggest.

comment:2 Changed 13 years ago by sol@…

Thanks for looking into it. Shouldn't dojo documentation at least state that this is the problem until a solution is implemented?

comment:3 Changed 13 years ago by dylan

Resolution: duplicate
Status: newclosed

duplicate of #1028

comment:4 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.