Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#10964 closed defect (duplicate)

dijit.form.ValidationTextBox Internet Explorer reset button deletes data.

Reported by: usr Owned by:
Priority: high Milestone: 1.1
Component: Dijit - Form Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

I have a html reset button and in Internet Explorer in deletes all the data that was in my dijit.form.ValidationTextBox? when the page was loaded. Chrome and Firefox do not have this problem.

Attachments (1)

Form.html (1.2 KB) - added by usr 11 years ago.
test of reset button in internet explorer

Download all attachments as: .zip

Change History (5)

comment:1 Changed 11 years ago by bill

You'll need to attach a test case, using the "Attach File" button as dijit/tests/form/Form.html seems to be working fine. Also, which version of IE does it fail on?

Changed 11 years ago by usr

Attachment: Form.html added

test of reset button in internet explorer

comment:2 in reply to:  1 Changed 11 years ago by usr

Replying to bill:

You'll need to attach a test case, using the "Attach File" button as dijit/tests/form/Form.html seems to be working fine. Also, which version of IE does it fail on?

I added an attachment. The problem is with IE 8.0.

comment:3 Changed 11 years ago by bill

Milestone: tbd1.1
Resolution: duplicate
Status: newclosed

OK, I see. Actually this is a dup of #2666. You need to use the dijit.form.Form widget rather than a native <form> node.

comment:4 Changed 10 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.