Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#10960 closed defect (fixed)

dojox.editor.plugins.TablePlugin doesn't set TD background color on IE

Reported by: youngho Owned by: Mike Wilcox
Priority: high Milestone: 1.5
Component: Editor Version: 1.4.0
Keywords: editor table plugin Cc:
Blocked By: Blocking:

Description

TablePlugin does not set TD background color on IE. But FF, Chrome, Safari works well.

You can see it from

http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/editor/tests/editorTablePlugs.html

Change History (5)

comment:1 Changed 9 years ago by Adam Peller

Owner: set to Jared Jurkiewicz

comment:2 Changed 9 years ago by Jared Jurkiewicz

Owner: changed from Jared Jurkiewicz to Mike Wilcox

Your plugin, Mike.

comment:3 Changed 9 years ago by Jared Jurkiewicz

The problem is due to how 'getSelectedCells' works. Basically, it only works if you select cells across a boundry. Just having a cursor inside the cell won't work. It needs to check for collapsed ranges, and then search up for an ancestor 'td' in those cases.

Fix coming.

comment:4 Changed 9 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [21828]) Fixing issue with setting background cell color on ie when selection is collapsed. Also fixed some 'leak' issues. That global really needs to go. It makes it impossible to use the table plugins in more than one editor in a page. fixes #10960

comment:5 Changed 9 years ago by bill

Milestone: tbd1.5
Note: See TracTickets for help on using tickets.