Opened 10 years ago

Closed 9 years ago

#10945 closed defect (duplicate)

Model based TreeGrid produces error with more than 3 layers

Reported by: Ganeshpuri Owned by: Bryan Forbes
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

Extending the programmatic TreeGrid? from test_treegrid_model.html from 3 to 4 layers makes the TreeGrid? fail. See attached examples: Setting line 54 to dataItems3Layers works, but setting dataItems4Layers produces the error.

It would be great to have this bug fixed, because I have variable layers (up to seven) via a data store, that come in through a model.

Attachments (1)

test_treegrid_model_4.html (3.2 KB) - added by Ganeshpuri 10 years ago.
reproduces described bug

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Ganeshpuri

Attachment: test_treegrid_model_4.html added

reproduces described bug

comment:1 Changed 10 years ago by Adam Peller

Owner: changed from bryanforbes to Bryan Forbes

comment:2 Changed 10 years ago by Yves De Bruyne

From my testing, seems to be closely related to #10872

comment:3 Changed 9 years ago by bill

Milestone: 1.51.6

1.5 is released, moving remaining tickets to 1.6

comment:4 Changed 9 years ago by evan

Resolution: duplicate
Status: newclosed

Duplicate with #10872, fixed by[23326]

Note: See TracTickets for help on using tickets.