Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#10914 closed enhancement (fixed)

grid: add paginator

Reported by: Matthias Sch. Owned by: evan
Priority: high Milestone: 1.6
Component: DojoX Grid Version:
Keywords: Cc: David Schwartz
Blocked By: Blocking:

Description

is it possible to add a paginator to the grid like: http://www.trirand.net/demoaspnetmvc.aspx

Attachments (2)

edg-pagination.JPG (36.6 KB) - added by evan 9 years ago.
EDG
pagination.patch (53.3 KB) - added by Adam Peller 9 years ago.
patch from Evan

Download all attachments as: .zip

Change History (17)

comment:1 Changed 9 years ago by Adam Peller

Cc: David Schwartz added

David may be able to point us at the discussion or another ticket. My take is that a paginator is a very different widget, since the 'virtual scrolling' feature seems directly at odds with pagination. It's hard to me to think of a case where the two would be needed together.

comment:2 Changed 9 years ago by David Schwartz

We are working on this feature for grid. There is no ticket in place for this feature at this time; I suppose we can now use this one.

BTW, I don't understand why it's so hard to envision having paging and scrolling working together. In fact, the example provided above uses both.

comment:3 Changed 9 years ago by Adam Peller

David, that example has a scrollbar. It does not use virtual scrolling. Virtual scrolling and pagination defeat each other. Having the overhead of both in the same widget is probably undesirable.

comment:4 Changed 9 years ago by evan

By "I don't understand why it's so hard to envision having paging and scrolling working together. In fact, the example provided above uses both.", I think David also meant using paging and real scrolling(non-virtual) just as the sample shown. Yes, pagination conflicts with virtual scrolling, so once pagination finished, only one can be enabled in EnhancedGrid?. Will use this ticket for tracking EDG pagination.

comment:5 Changed 9 years ago by bill

Owner: changed from bryanforbes to Eavn

looks like these are ones that evan is working on

comment:6 Changed 9 years ago by bill

Owner: changed from Eavn to Evan

Changed 9 years ago by evan

Attachment: edg-pagination.JPG added

EDG

comment:7 Changed 9 years ago by evan

The new EDG pagination (targeting 1.6) looks like as attached "edg-pagination.JPG". Patch's being uploaded...

comment:8 Changed 9 years ago by Adam Peller

should a paginating grid be a separate widget? how much of the grid or edg grid code applies? a paginating grid widget would likely be much smaller and lighter than the existing grid widget.

Changed 9 years ago by Adam Peller

Attachment: pagination.patch added

patch from Evan

comment:9 Changed 9 years ago by Adam Peller

requires patches from #11734

comment:10 Changed 9 years ago by evan

Once the "pagination.patch" applied, please use dojox/grid/tests/enhanced/test_enhanced_grid_pagination.html for try

comment:11 Changed 9 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [23011]) Fixes #10914. Proxy commit for evan (CCLA). Add grid pagination feature and associated test. !strict

comment:12 Changed 9 years ago by Douglas Hays

(In [23019]) Refs #10914. Proxy commit for evan (CCLA). Add missing template.

comment:13 Changed 9 years ago by Douglas Hays

(In [23028]) Refs #10914. Proxy commit for evan (CCLA). Fixed incorrect encoding of the file in trunk. Code clean: coding style, remove redundant code, more cleaned fetching logic. Reuse connect/disconnect in _Plugin base class. Fixed a potential memory leak issue caused by mixin'ing wrong parameter in _createPaginators()

comment:14 Changed 9 years ago by bill

Owner: changed from Evan to evan

comment:15 Changed 9 years ago by bill

Milestone: tbd1.6
Note: See TracTickets for help on using tickets.