Opened 9 years ago

Closed 8 years ago

#10886 closed defect (worksforme)

dojox.gfx3d fails in Silverlight: "null or not an object"

Reported by: Erik Demaine Owned by: Eugene Lazutkin
Priority: low Milestone: 1.6
Component: DojoX GFX Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

Attached is a very simple beginning of a dojox.gfx3d test: all it does is create a gfx surface and create a viewport within. But in Silverlight on IE, something seems to be wrong with the object nature of the surface, because the createViewport method call isn't succeeding (presumably because it's not happy with the value of 'this'? I'm not sure). Here's the console log:

LOG: surface: [object Object]
LOG: type: object
LOG: createViewport: function(){
var _81=this.createObject(dojox.gfx3d.Viewport,null,true);
_81.setDimensions(this.getDimensions());
return _81;
}
(Error) 'null' is null or not an object

The offending line is var viewport = test.createViewport (); I've had errors within the Dojo code before (caused by my code), and IE correctly reports the line number within dojo.js. So it seems to really failing on the call itself, not within the call. Strange.

Attachments (1)

simple3d.html (687 bytes) - added by Erik Demaine 9 years ago.
demonstration of createViewport bug

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by Erik Demaine

Attachment: simple3d.html added

demonstration of createViewport bug

comment:1 Changed 9 years ago by Eugene Lazutkin

Milestone: tbdfuture
Priority: normallow
Status: newassigned

comment:2 Changed 8 years ago by Eugene Lazutkin

Milestone: future1.6
Resolution: worksforme
Status: assignedclosed

It was fixed in he trunk. Please retest.

Note: See TracTickets for help on using tickets.