Opened 9 years ago

Closed 9 years ago

#10867 closed defect (wontfix)

Omitted custom labels default to numeric values

Reported by: Douglas Hays Owned by: Eugene Lazutkin
Priority: high Milestone: tbd
Component: Charting Version: 1.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

Run test_labels2D.html.
Most of the tests exhibit the anomaly but the vertical axis in test 4 highlights the issue. The labels are January...May and the next label is omitted and thus displayed as the number 6. I believe this is a defect in this case since a blank label would be more appropriate. The fix is just return the empty string in getNumericLabel at the end of the if statement searching the labels array. If we must return numeric values in other scenarios with omitted labels, then perhaps an optional boolean can be given in the addAxis kwArgs object. Optionally, we can force the labels array user to include additional blank labels but it may be impossible to always know how many blanks need to be included.

Change History (1)

comment:1 Changed 9 years ago by Eugene Lazutkin

Resolution: wontfix
Status: newclosed

This behavior is by design. If you want to show an empty label instead of a numeric value, just include an empty label, or use a procedural way to generate labels with a function, and return whatever you like.

Note: See TracTickets for help on using tickets.