Opened 10 years ago

Closed 10 years ago

#10851 closed defect (fixed)

lightbox navigation on ie8

Reported by: hungerburg Owned by: anonymous
Priority: high Milestone: 1.5
Component: General Version: 1.4.2
Keywords: Cc:
Blocked By: Blocking:

Description

The lightbox.dialogue navigation buttons (prev, next, close) are in the html-source before the dojoxLightboxText and so are not clickable in ie8, though they are in firefox.

I worked around this by styling the dojoxLightboxText div as width:80%. curiously, applying z-index to the items in question did not help.

An example on sitepen.com works, maybe because there tundra defines a text-align:center on the body...

Change History (4)

comment:1 Changed 10 years ago by dante

Resolution: worksforme
Status: newclosed

i am unable to reproduce this with IE 8.0.6001.18702

I did just fix another related CSS bug, perhaps that fixed it as well? please reopen if persists.

comment:2 Changed 10 years ago by dante

Milestone: tbd1.5
Resolution: worksforme
Status: closedreopened

discussed in irc: turns out this is reproducible based on the inclusion of dojo.css with a default margin/padding:0 set for dojoxLightboxText div (or inherited parent).

comment:3 Changed 10 years ago by hungerburg

thank you dante, I changed my workaround in css .dojoxLightboxText { margin-right: 50px; /* unclickable NavButtons? in IE8 */ } though even margin-right: 0px; fixes the problem for me...

comment:4 Changed 10 years ago by dante

Resolution: fixed
Status: reopenedclosed

(In [21729]) fixes #10851 - actually committing the ie8css fix thing from last week

Note: See TracTickets for help on using tickets.